Modifying APA style and non-USA dates format

I'm currently modifying (or lets say more customizing) APA style to my faculty's requirements of quoting (and for a Journal they publish). I have used Slovenian (sl-SL) locale preference to start with and then fixed the rest that was not yet ok (using http://editor.citationstyles.org/about/). The biggest problems I have encountered are dates. Even by using numerical and SL locale they are in form 2013-5-1 but should be 1. 5. 2013. I tried numerous codes and at different places but with no success.

In short I'm traying to do this:

in text citation:
(Zotero forum, 2013)

bibliographic citation
Zotero forum. (2015) [Slovenian word for retrieved] 1. 5. 2013 [Slovenian word for from] https://forums.zotero.org/post/category/11/

(the Slovenian words parts is taken care of and the fix works, just the date is bunging me)
  • Is this the way dates are generally formatted in Slovenian? If so, we can change this in the locale.
    Until then, you can put
    <locale xml:lang="sl-SI">
    <date form="numeric">
    <date-part name="day" suffix=". "/>
    <date-part name="month" suffix=". " range-delimiter="/"/>
    <date-part name="year" prefix="-" range-delimiter="/"/>
    </date>
    </locale>

    in the code right after the info section (i.e. after </info>
    you'll have to use the code editor for that, I don't think it's easily possible in the visual editor.
  • Thank you for the fast replay.

    Code does work partly. It's now 1. may 2013,... trying to figure how to tweak it to be stated "5" instead of "may". It doesn't do that despite the: date form = numeric.

    Well I don't know if all Slovenian institutions use this form, but for now I haven't find any that does not. It is custom to put year last. In some cases form as 1. May 2013 is also used.

    there are also some other tweaks that should be changed in locale I can submit them if someone can fixes them.
  • edited May 1, 2013
    sorry, the month line should have been
    <date-part name="month" suffix=". " form="numeric" range-delimiter="/"/>
  • Excellent,... THANK YOU!!.

    Probably I'll mess up some other parts of the code till I'm finished, but for now this was a real big nut to crack for a beginner like me :)
  • It's me again :). I have now almost completed the whole modification of the "Slovenian APA standard" to fit our journal. The latest problem that I have is with in-text citation and pages. E.g.:

    I believe I can fly (Kelly, 1996, str 53).

    But should be like

    I believe I can fly (Kelly, 1996: 53)

    Everything else should remains as it is. I have searched the web and found a few instructions that you gave to others with similar problems, but i cannot fund them to work.
  • change
    <group delimiter=", ">
    <text macro="author-short"/>
    <text macro="issued-year"/>
    <text macro="citation-locator"/>
    </group>


    to

    <group delimiter=": ">
    <group delimiter=", ">
    text macro="author-short"/>
    <text macro="issued-year"/>
    </group>
    <text variable="locator"/>
    </group>
  • Excellent,... it worked like charm. Thank you!!
  • Hello!

    I'm in a need for some advice. The style which you helped me modify works well, but i have a problem with one "comma" that is placed improperly. Until now, this didn't present a problem, since i have simply manualy deleted in it the final version of the text. However now i have a bigger text that will be reviewed several times and i would like that Zotero would automatically cite correctly. The problem is with the comma before the last author when there is more two authors:

    (Dorn, Levi, in King, 2005)

    while it should be just

    (Dorn, Levi in King, 2005).

    In Slovenian language normally , should not appear before "in". How do i fix this.
  • edited July 7, 2016
    add delimiter-precedes-last="never" to the line(s) starting with <name ...
  • Thank You!!
  • And once again I have a problem. To be more in line with the rest of the world APA style we are making huge amendments to the style. With your help I have restored or modified some of the above mentioned issues, hoverer I'm currently stuck with legislation.
    Here is my case.
    I have developed the following example to use in Zotero editor.

    [
    {
    "id": " XXXXXX "
    "type": "legislation",
    "title": "Law on Zotero is awesome (LoZ) ",
    "container-title": "Official gazette",
    "volume": "1",
    "URL": "",
    "number": "2",
    "issued": {
    "date-parts": [
    [
    "2006"
    ]
    ]
    }
    }
    ]

    The form that we use is the following
    In text citation:

    First citation ("Law on Zotero is awesome [LoZ]", 2006) all the next (''LoZ'', 2006) –I managed to add '' and abbreviations (namely delete the text and change the brackets to [ ) I just enter/correct manually.

    The problem is with the bibliography, where the form should be:
    Law on Zotero is awesome (LoZ). (2006). Official gazette, (2). [Official gazette is in italics. the style is like for a journal. I can cheat by using this category, but for other papers i would like to have a proper database - to have paper categorised as papers and legislation as legislation.

    I managed to get so far:

    Law on Zotero is awesome (LoZ). (2006). Official gazette, 1 – I can get the volume to appear, but not the issue, yet I need number/issue and no volume.
    Can I get some help?
    Tnx
  • can't say anything without seeing the code (put on gist.github.com link to from here)
  • edited 8 days ago
    I hope this works. Can't post code here



    link is here:
    https://gist.github.com/anonymous/5cf34b72188a516297dcc75318118d57
  • You specify that behavior here:
    https://gist.github.com/anonymous/5cf34b72188a516297dcc75318118d57#file-code-json-L284

    Presumably you'll want to have a separate condition for legislation, i.e. remove legilsation from that line and then do something like
    <else-if type="legislation">
    <text variable="number" prefix=" (" suffix=")"/>
    </else-if>

    inserted between lines 292 and 293
    (note this will work only so well with other styles, though; we otherwise assume that "number" is the public law number as used in the US for legislation, so perhaps using issue would be better)
  • THANK YOU!!

    The thing is that that when i use Sl locale i only get "Statut" as an option for categorising source that is the most close to legislation (legal bill or act). And translations of Zotero and offered fields for entering info on the legislation are not that useful for Slovenians settings. On this account there is probably the difference for number and issue and i assumed that if using different style that there will be a problem :).

Sign In or Register to comment.