Triple Curly Braces around CAPAUTHOR in Bibtex Export

So, I have two zotero items authored by ANDRA. I export to bibtex they end up in the .bib export as "author = {{{ANDRA}}}".

The latter of the two renders in my compiled LaTeX document as ---------- where it should say ANDRA.

If I remove the third curly brace pair by hand, it renders fine... but I'd rather not have to do that.
Any thoughts on what's happening?
  • edited April 25, 2013
    this a a confluence of several bracketing mechanisms in Zotero's bibtex export.
    We're aware of this, and generally interested to change this, but it _is_ valid bibtex, so the failure of either biblatex or biber (I forgot which) to recognize it is a problem on their part, and on our side we need to tread with great care not to break something else here.
  • Hm. I see. Thanks for the swift response!
  • (there's a dedicated custom biblatex translator available somewhere on the forum - should be easy to find - you could try that out & see if the developer fixed that).
  • Is this what you mean?

  • no - I meant the one linked to 2nd post from the bottom here:
    you can use it together with autoZotBib, though (by using the instructions for using Robin's custom bibtex translator and switching out the translator ID numbers).
  • Well, it was worth a try. Installed fine, but It doesn't seem to have done the trick.
    Thanks anyway.
  • you can post there - it's maintained separately, since this affects mainly LaTeX users s/he may be quicker to fix it that the general bibtex translator which needs to be stable across a lot of different settings.
  • The answer to this, for interested readers, is that this is mostly not zotero's fault. In the natbib chicago style, the second identical author is listed as ------- . The seemingly unpredictable/inconsistent behavior, in which sometimes this happens and sometimes it doesn't, occurs if there's a difference in the number of curly braces. That's why I was seeing different behavior under different perturbations of curly braces.

    So, my fault.
Sign In or Register to comment.