Zotero 4.05 failing to save items to library

Error report: 470647925

Zotero 4.05 running on FF 20.0 and OS X 10.8.3 has stopped saving most items. New York Times will work, but all academic sites including Google Scholar, JSTOR, university library, and others lead to error message or no action. Zotero cannot retrieve metadata for pdfs that are placed directly in the Title field.


  • could you provide a specific URL and also add a debug ID:
    for a failed attempt from that URL.
  • The Debug ID is D1185320143.

    Tried Google Scholar twice and then Taylor & Francis through University proxy.

    Thanks much.

  • I'd really want the URL you used so we're talking about the same page.
    Is google through the proxy, too, or not?
  • Here is another: The Debug ID is D1733072418

    URL is http://scholar.google.com.eres.library.manoa.hawaii.edu/scholar?hl=en&q=habermas+on+cloning&btnG=&as_sdt=1,5&as_sdtp=

    I tried to grab the first item on the list.

    This is Google Scholar run through the proxy at University of Hawaii


  • can you try without the proxy? (google scholar that is) - no need for another debug, but it'd be good to see if it works (if you get auto proxy redirection you can (temporarily) turn it off in the proxy tab of the Zotero preferences).
  • When I turn off Proxy redirection, I can indeed get single items from Google Scholar. This is different. However, when I click on the yellow folder icon for multiple citations, I cannot get any. This is true for when I click on only one item or multiple items. In these cases, nothing happens, not even an error message. Nothing is downloaded to the library, neither citation nor pdf.

  • Dan - what does the debug say?
  • one more question actually - do you happen to have "Don't remember history" set in Firefox or some other (unusually) strong privacy setting?
  • That was the problem. I hadn't noticed the privacy setting but when I changed it I could download items to the library. Thanks.
  • (just to be clear, this isn't because Zotero needs to spy on you ;-) - working with proxy servers as well as the google scholar translator require the ability to set a cookie, which Firefox doesn't allow with some settings enabled. IIRC that's actually a Firefox bug in the way it works now).
Sign In or Register to comment.