Webdav server found - Zotero 4.0.4 on Mac

Before upgrading to Zotero 4.0.4, I was successfully syncing my attachments via webdav (specifically owncloud) on two Linux computers and a Mac. After upgrading Zotero on the Linux machines and the Mac (as well as switching from one Mac laptop to another), webdav syncing is no longer working on the Mac. (The LInux laptop and desktop sync fine.) On the mac (running Mountain Lion), I get the message "The server ... could not be found" when I try to verify the server. The sync settings on all three computers, including server address, password, etc., are the same. The error shows up with both the Firefox extension and the standalone version.

Not sure if this is a bug on the Mac version of 4.0.4, but any suggestions would be appreciated.
  • Do you connect via a system proxy?

    Are you able to sync metadata with the Zotero server?
  • edited April 15, 2013
    Not 100% sure what you mean by connecting via a system proxy. I don't think I do though.

    Metadata does sync with the Zotero server.

    Is there a recommended way I could uninstall and reinstall Zotero on the Mac, including preference files, without harming my library?
  • Just updated to 4.0.5, and webdav syncing still produces "server not found" error message on the Mac.
  • Can you provide a Debug ID for a Verify Server attempt that fails?
  • Here you go: D339743994

    Thanks for your help on this.
  • If you go to System Preferences, Network, click the connection you're using (e.g., Wi-Fi), Advanced, Proxies, is anything in that list (e.g., "Automatic Proxy Configuration") checked?
  • Only "Use Passive FTP Mode" is checked. Nothing under the proxy settings.
  • edited April 16, 2013
    Do other hostnames work in the Sync preferences? E.g., if you put in www.google.com, does it give you the same message, or does it say "https://www.google.com/webdav/ is not a valid WebDAV URL" (as it should)?
  • Entered http://www.google.com/webdav/zotero/ for the server.

    Clicked "Verify Server."

    Error message: "The server www.google.com could not be reached."

    If I use https and the above server address, I get "https://www.google.com/webdav/ is not a valid WebDAV URL."
  • Interesting. Simon might have some thoughts on this, but I don't really have any ideas here. People have reported problems with system proxy settings in Zotero 4.0 (due to an issue with the underlying Mozilla framework), but you don't appear to have those set. This really looks like that, though, since HTTP is more likely to be proxied than HTTPS.

    Are you running any security software?
    The error shows up with both the Firefox extension and the standalone version.
    Oh, and I just noticed this. This happens with Zotero for Firefox too? There shouldn't be any difference between what Firefox can connect to and what Zotero for Firefox can connect to, so if that's the case, something very strange is going on.
  • On my Mac I am running Symantec Endpoint Protection, though syncing worked in the presence of SEP before.

    I agree with your comment about the Firefox extension and standalone Zotero. But as I said, the sync error shows up with both.

    To summarize, I have no troubles syncing with Zotero 4.0.4/4.0.5 on my Linux machines. When I was issued a new Macbook Pro, my OS changed from Lion to Mountain Lion. I can't remember if I had the problem with Zotero 3.x on the new laptop or if I upgraded to 4.0 immediately, but the syncing problem showed up on this new Mac.

    Is there a way to completely uninstall and reinstall Zotero? I could use some help finding all the Zotero preference files lurking in Library to do a scorched Earth uninstall. Of course, I would back up and would like to reuse my current Zotero data folder.
  • edited April 18, 2013
    Can you try disabling the Symantec software? There appears to be a proxy-related bug in the latest version of the Mozilla framework that we use, so the fact that this worked before isn't really relevant.

    An uninstall/reinstall is highly unlikely to accomplish anything, particularly if this is happening in both Standalone and Firefox (but really in general).
  • You could also try reinstalling Zotero Standalone 3.0.14 to see if that works, since the newer framework is in 4.0:

  • (Also, is there a reason you can't just use HTTPS as a workaround? It's possible to whitelist self-signed certificates in Standalone if need be.)
  • edited April 20, 2013
    As much as I liked using my own server for syncing, this issue with my Mac was proving too intractable and time consuming. I purchased Zotero storage and am using your servers for syncing. Syncing is now working on the Mac as a result.

    Thanks for your help and to everyone at Zotero for providing such a fantastic research tool. I teach my undergraduate students how to use Zotero and have received some very positive feedback.
Sign In or Register to comment.