automatic pdf attachments not working in Standalone

I noticed today that pdfs are no longer being attached to items I grab when using Standalone. I tried it with Standalone closed (using the browser version of Zotero), and the pdf attachments did work.

I remember this being an issue for a while in the early days of Standalone, but I've been using it often for several months recently without any problems grabbing pdf attachments when I grab references. I'm not sure if this is related to the new updates. Zotero just automatically updated (4.0.4) and I just manually updated Zotfile too just in case (to 2.3.4).

When I try to grab a reference using Standalone, the new little box at bottom right shows the pdf attachment first greyed out and then in red, with a red x next to it.

I've double checked my preferences, but I can't think what else to do. Is this a bug?
  • we'd need one sample URL exactly as you see it.
    And that's with Chrome, Safari, or Firefox?
  • edited April 11, 2013
    Here are three for which the pdf attachment didn't work in Standalone (but *did* work in the browser-integrated version):

    Investigating further, I did get pdf attachments to work (even in Standalone) from articles grabbed from JSTOR and a Wiley journal.

    I'm using FF 19.0.2 (though looks like there's an update downloading in the background).

    (The "saving to my library" box for Standalone grabs also stays open for a really long time, and sometimes doesn't go away unless I click it. When using the browser-integrated version of Zotero, grabbing anything does work eventually but freezes up/greys out my browser for several seconds -- hence why I prefer Standalone.)
  • and these are the URLs as you see them - i.e. you are on campus and have direct institutional access without a proxy (that would be part of the URL)?

    If so, could you provide a debug ID for the first one of those examples?
  • These are the URLs as I see them. I am not on campus, and I am using a proxy, but the proxy that we use does not put anything into the URL. Sorry, meant to add that I am using a proxy. It's an "automatic proxy." The thing is, this process has been working in the not too distant past.

    I did the debug anyway. The ID is D657326436.
  • If you could try this on campus when you get a chance that'd be helpful additional data.
    Dan - anything in the debug?
  • I can try using a VPN if that would help.
  • yes that would help.
  • It worked with the VPN (proxy turned off).
  • edited April 11, 2013
    Also, as I mentioned above, it's not every journal/site/publisher that is a problem. I did get some to work with the proxy.
    (Still, even though it worked with the VPN, the "saving to" box is staying up perpetually until I click on it, which is presumably not what's supposed to happen.)
  • So it's the proxy.
    We had a similar problem with a general proxy somewhere - Dan troubleshooted that, he might remember.
  • (5)(+0000823): CookieSandbox: Managing cookies for

    (2)(+0000152): Downloaded PDF did not have MIME type 'application/pdf'
    in Attachments.importFromURL()

    (3)(+0000000): <!DOCTYPE html
    PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "

    It looks like Standalone (which is responsible for saving PDFs, not the connectors) might just not be using the proxy. As adamsmith says, we've had a number of issues lately with this. The details have varied, but it's possible that system proxy functionality is just broken in the latest version of the Mozilla framework that we use. I'm guessing the pages that worked had publicly accessible PDFs.

    Not much to suggest here other than using either the VPN or Zotero for Firefox. (Technically there's a way to use Zotero for Firefox with the connectors, but it's not recommended, and you have to be careful not to open Standalone while Firefox is open.) Hopefully this will be fixed in the next version of the framework.
  • Here are two that did work. They are not publicly available pdfs.
Sign In or Register to comment.