• It seems that the OVID translator is missing on my computer. Has it been disabled, or is my installation broken?
  • you can always see a list of active translators here:
    http://zotero-translator-tests.s3-website-us-east-1.amazonaws.com/ (with tests)
    or here:
    with code
    Ovid has not been discontinued, no, but I'm not sure PsycARTICLES works with the existing translator.
  • Any ideas why the ovid translator is not installed on my computer and how to install it?
  • you're positive it's not there - i.e. you have looked in the translator directory?
    If so, I have no idea why that would be the case, no. You have updated your translators I assume?
    Installing is easy - just download it from github into the translator directory - since the ID exists on the repo it should start updating.
  • Yes, it was not there. For some reason I had only 300 translators. After resetting the translators, I now have 434 translators, including ovid.

    The translator now attempts to import search results, but it gets incorrect articles. And it does not import a single article.

    Is there some technical reason why the translator does not work, or is it just that no-one has fixed it? If latter, I might take a shot at it.
  • please do take a look, there is no reason apart from the fact that automated tests wouldn't work so we don't notice problems with Ovid easily (unless someone reports them).
    The translator was submitted by Ovid Technologies, so I won't be able to tell you reasons for particular code decisions. If you can't get it to work, I still have the contacts at Ovid and we can try to get them to fix it, but last time that took quite some time, so if you can do it that'd be great.
  • The PsycARTICLES database seems to be ajax based, so that complicates things.
  • sorry, Aurimas and I can't help here - we have PsycARTICLES access through EBSCO. I have access through Proquest via another affiliation, but no Ovid.
    I tested yesterday that standard Ovid SP works.
  • Are there any translators that support databases with that have ajax user interfaces?

    I could set up a proxy server that would allow you to access Ovid PsycARTICLES.
  • The only ones I know of are ARTstor.org and twitter. AFAIK, the only problem used to be performing detectWeb on content changes, but that should now be possible https://github.com/zotero/zotero/pull/218 We still have not updated the translators for those to use this new feature though, but see https://github.com/aurimasv/translators/commit/8a687f9c7293a439fe87705424a7f717f16c5958 to get the idea.
  • I am trying to import articles from the journal Academic Medicine which is available through OvidSP for our institution. The "Save to Zotero (DOI)" icon is active on my browser (Safari 6.05, MacOS 10.8.4) but when I try to save the reference of the article, the system displays the “An error occurred while saving this item...” message.
    Here is an exemple URL of a page which does not work
    However, when I use the wand icon of the Standalone application and manualy copy/paste the DOI, the reference was imported. An idea why it not working through the browser ?
  • I'm not sure why you're seeing "Save to Zotero (DOI)". Is that URL exactly as you see it in Safari?

    The translator was not working with Chrome/Safari though, so perhaps it was the same problem.

    Updated the translator. It should now work in Safari/Chrome. Update your translators via Preferences -> General -> Update Now... in Zotero Standalone. Restart Safari and try again.
  • Sorry, the original URL was modified by some complex redirections. The correct URL was:

    Following your instruction, I updated the translator in Zotero Standalone, restarted Safari but unfortunately the problem is still there. The same error message is displayed in the lower right corner of Safari.
  • Are you still seeing "Save to Zotero (DOI)"? What version of Zotero Standalone and Zotero for Safari are you running?

    Could you generate a Debug ID for (1) refreshing the Ovid page and (2) attempting to import an item? Submit them both to Zotero and post them here.
  • Yes, I still see "Save to Zotero (DOI)" in the toolbar of Safari. The version of Zotero Standalone is 4.0.9. I do not know where to look the version of Zotero for Safari.

    I followed the instruction you said and I got the following Debug ID: D155171387
  • (3)(+0000000): Translators: Looking for translators for
    http://ovidsp.tx.ovid.com/sp-3.9.0b/ovidweb.cgi?QS2=[very long hex string]

    (4)(+0000004): Translate: Binding sandbox to
    http://ovidsp.tx.ovid.com/sp-3.9.0b/ovidweb.cgi?QS2=[very long hex string]

    (4)(+0000000): Translate: Parsing code for Ovid

    (3)(+0000000): Translate: detectWeb

    (4)(+0000000): Translate: Parsing code for unAPI

    (4)(+0000000): Translate: Parsing code for COinS

    (4)(+0000000): Translate: Parsing code for DOI

    (3)(+0000001): Translate: All translator detect calls and RPC calls complete

    (5)(+0000000): Translate: Running handler 0 for translators
  • Dan, is there no indication of an import attempt? (on a side note, I really wish we output some debug data indicating which translator is returning what and which translator is ultimately chosen)

    @scherly, before you proceed with what's below, could you try one more time generating a debug ID for an attempt to import item from that page. I.e. enable debug logging and lick the URL bar icon, then submit.

    Having said that, my apologies for not catching this later, but we did not support the types of Ovid pages you were looking at (it would have imported if you followed the link to Abstract Reference, for instance). That should be fixed now, so update your translators as per above and try again.
  • scherly: We probably don't need another Debug ID.

    aurimas: There is, but it's DOI. Isn't the issue that this isn't supposed to be DOI? But I'm not sure why the DOI is failing, either, given that it's valid, and CrossRef returns a result. It works for me via Add Item by Identifier.

    (4)(+0014220): Translate: Parsing code for DOI

    (3)(+0000001): Translate: Beginning translation with DOI

    (3)(+0000001): Translate: Creating translate instance of type search in sandbox

    (3)(+0000000): HTTP POST {} to

    (4)(+0000001): Translate: Binding sandbox to
    http://ovidsp.tx.ovid.com/sp-3.9.0b/ovidweb.cgi?QS2=[long hex string]

    (4)(+0000000): Translate: Parsing code for CrossRef

    (3)(+0000000): Translate: Beginning translation with CrossRef

    (3)(+0000002): HTTP GET http://www.crossref.org/openurl/?pid=zter:zter321&url_ver=Z39.88-2004

    (3)(+0000003): Connector: Method getSelectedCollection succeeded

    (3)(+0000250): Translate: Could not find a result using CrossRef:
    stack => serializeToString@[native code]


    [native code]
    line => 23
    string => TypeError: Type error
    url => undefined
    downloadAssociatedFiles => true
    automaticSnapshots => true

    (2)(+0000000): Translate: Translation using CrossRef failed:
    thrown exception => No items returned from any translator
    url => undefined
    downloadAssociatedFiles => true
    automaticSnapshots => true

    (5)(+0000000): Translate: Running handler 0 for error

    (5)(+0000001): Translate: Running handler 0 for done

    (2)(+0000000): Translate: Translation using DOI failed:
    thrown exception => DOI Translator: could not find DOI
    url => http://ovidsp.tx.ovid.com/sp-3.9.0b/ovidweb.cgi?QS2=[long hex string]
    downloadAssociatedFiles => true
    automaticSnapshots => true

    (5)(+0000000): Translate: Running handler 0 for done

    (5)(+0000000): Translate: Running handler 1 for done
  • Yeah, I was just asking to figure out the DOI problem. I can't reproduce this either with that DOI, but I haven't tested with Safari.
Sign In or Register to comment.