How to make zotfile cite the right page number

do you know how to make zotfile cite the right page number in a book in which there are, for instance, the first 10 pages numbered with roman numbers and the rest of the book numbered with normal numbers?
At the moment Zotfile cites as the first page of the book would be page number 1, but in reality page number 1 is 10 pages after.
Hope to have been clear enough. Many thanks.
  • that's come up before - I don't believe it's currently possible. If the pdf is aware of the pagination (i.e. it displays "1" and not "10" for the real page 1) it may be doable to fix this, but it would required a patch to Zotfile. If the pagination isn't stored as data in the PDF I don't think there's a way to do this at all.
  • The easiest way to do this would be to rely on Zotero "# of pages" field. That's what ZotFile does at the moment with article/book chapter (using the "Pages" field) when the option "Use actual article/book chapter page for highlighted text snippets" (in the Advanced Settings tab of the ZotFile prefs) is checked.
  • I see. Using the field "# of pages" it should be possible to set the number of introductory pages and the number of pages of the main text. It might appear something like "viii, 239." However, for the moment there is not a solution to this issue, right?
  • Right. "viii+239" "viii-239" "viii, 239"...
Sign In or Register to comment.