Word plugin: editing citation in footnote gives "You must place the cursor in a Zoter citation"

Using the Word plugin, adding citations in footnotes is never problematic. Editing them is, however: this often (perhaps always) gives the error "You must place the cursor in a Zoter citation to edit it". What is this, and how can I avoid it?
  • and you have the cursor in the footnote when you try? Or next to the footnote number in the text?
  • It works for me when I place the cursor within the footnote (which turns grey when focused) before clicking the "Zotero Edit Citation" button.
  • edited February 13, 2013
    Sorry, to be clear: I'm using a non-footnote, in-text citation style.
    Then within a text footnote, I insert an in-text citation. No problem so far. When I place the cursor within that citation (the field becoming grey), and I hit "edit citation", that's when I get the error.
  • ah ok. That, too, works in LO. Are you on Windows or Mac?
  • mark - did this every get solved? I don't have Word to test, but this works in LO of Windows, too.
  • It works for me when I place the cursor within the footnote (which turns grey when focused) before clicking the "Zotero Edit Citation" button.
    Yes but when the cursor is at the very beginning or at the very end of the citation, even if the citation turns grey, I got the error message. Slightly annoying but I think nothing can be done (but I always wonder why does it turn grey if it's not considered as being in a citation?). (with word 2010, win7, with footnote styles).
  • I never had this problem with Word 2010, but with 2013 on Windows 8, I cannot edit the citation. The first time I had the cursor in the middle of the footnote, no go. Put it on the footnote reference in the document, same thing. Highlighted the footnote reference, same thing. Doesn't matter where I put the cursor, I get this error.
  • Have you tried in a fresh document? With a non-FN citation style?
  • This is a new document with the first footnote but it is saved in 2013 format macro enabled. I created a plain 2013 document and it seems to work. Maybe there is an issue with the macro function.
  • I had a similar problem. I inserted a footnote but then when I tried to edit the footnote an error message popped up saying I needed to place the cursor in the citation, which I had done. I'm using Microsoft 2010 and it was a document with Headings. I tried doing the same thing in a document without headings and it worked fine. Is there a way to fix this though? Both Zotero and Headings are important parts of my paper writing process!
  • I find the inability to edit a footnote to be true ONLY for the FIRST footnote of every document. I can edit the following footnotes no problem. So if I have to edit the first footnote, I simply replace it with a new one. I'm curious why this is, but it's only a significant problem for footnotes with several citations in it.
Sign In or Register to comment.