Javascript error when using timeline, plus error reporting fail

If I try to display a timeline with my main library selected, I get this error:
Caught exception: TypeError: v1 is null

The error happens three times, then the timeline displays but there are no items on it and the drag-to-scroll doesn't seem to work properly. If I select a sub-collection instead of the main library, timeline works normally. There are 1673 items in my main library, if that's relevant. I'm on Zotero 3.0.13 standalone, Linux 32-bit, and firefox 18.0.2 if it matters (though I doubt it does, since I'm using standalone?)

When I tried to use the "report errors to zotero" link in the help menu, zotero took over my CPU and became unresponsive, until I killed its process after about 3 minutes.
  • I have exactly the same problem. Previously I didn't have any problems in creating a timeline from the entire library. This problem also appears in one sub-collection, which happens to be the one with the most items. Therefore I suspect that this error might have something to do with a limitation in the maximum number of items in the library or collection.

    Could somebody provide some assistance on this?
  • You'll probably need to narrow this to the smallest set of items that triggers this. Create two temporary collections and copy all of your items (or all of the items from the subcollection that triggers this) to one of them. If the problem occurs, copy half of the items to the second collection and then remove those items from the first collection. Then see if it happens in each. If it doesn't happen in just one of them, remove all the items from the one that works, and repeat the process of copying half...
  • edited July 8, 2013
    (If it's just about the number of items in a collection, that may not help—you'll just end up with two halves that work—but this will help determine whether it's a single item that's causing this.)
  • Dan thank you very much for your feedback and tips, they have been very helpful indeed! I have more or less used your methodology and finally isolated the item in the sub-collection that was triggering the error. Therefore the problem was not caused by the size of the sub-collection. I am not sure why Zotero did not like the particular item, but I am going to create it again and I guess the situation will be resolved.

    Again, many thanks for your help!
  • Do you still have the item? If so, can you export it to Zotero RDF, open the RDF file in a text editor, create a Gist, and post the URL here?
  • I hope I have done this correctly:

    Let me know if you need anything else.
  • Also, what I find quite odd is that it seems that I cannot create a timeline for an entire collection, incl. the items in the related sub-collections. If I want to see these items in a timeline I need to either create separate timelines for each sub-collection or a single timeline for the entire Zotero library.

    So my question is: Is there a way to create a timeline for a collection that will include all the items within?

    Btw I have already changed the settings for recursive collections and I can see the items of the sub-collections at a higher level, but this did not make any difference for the produced timelines.
  • edited August 27, 2013
    with recursive collection on, you should be able to select all items in the center panel and create a timeline, though, no?

    uh, never mind
  • FWIW, it looks like you have the authors entered incorrectly for that item. That shouldn't matter for the timeline (and doesn't for me), but they'll show up incorrectly in citations: Personal authors must be in two-field mode in the form Firstname, Lastname
  • OK, thanks for the author tip. I thought I could use single fields for authors too.

    Regarding timelines, I cannot create them by selecting specific items, since the timeline created is still based on all of the items within the specific collection. On the other hand if I am not in a specific collection but in "My Library" and select some items (that probably belong to different collections) for the creation of a timeline I get the same error message "Caught exception: TypeError: v1 is null".
  • I also have the similar problem "Caught exception: TypeError: v1 is null"
Sign In or Register to comment.