Using the old database on a new computer...

Hi all,

at the moment I am using zotero standalone (3.0.13) on my University pc (O.S windows xp pro sp3). I tried to install a completely new version of zotero standalone (3.0.13)(downloaded from the site) on my home pc (OS windows 7 home edition); after that I copied the "storage" folder from my old pc (with all my library) to the new one, I opened zotero, set user folder for database, restarted and I got this error:
" the currently selected data directory is not compatible with Zotero Standalone, which can share a database only with Zotero per Firefox 2.1b3 or later.
Upgrade to the latest version of Zotero per Firefox first or select a different data directory for use with zotero standalone".

although I thought they were the same versions, I noticed that the GUI is quite different. So I tried to overwrite all my new zotero standalone directory with the older one, I restarted zotero (on the new pc) and I got the same error. What is happening?

thank you

  • Hey there,

    So it looks like noone has never seen this kind of error, uh? :(

    Please, any suggestion would be very appreciated.

    Thank you
  • what this sounds like is that you're installing Zotero Standalone on a computer that has Zotero for Firefox installed in a really old version, is that possible?
  • And if you just copied "storage", you didn't overwrite your entire Zotero data directory.
  • edited February 13, 2013
    Hi there.

    No Adam, the pc is new. Never installed zotero or firefox. However, i think the problem is solved. I downloaded a portable firefox, I installed zotero plugin, i connected the zotero in firefox with the storage in standalone folder, it asked me if I want to upgrade, said yes, told me upgrade was successufully complrte and it opened a completely empty library :(. So that, i copied the last sqlite database file, reopened it and it looks like i have my entire complete library.
    Thank you
  • edited February 13, 2013
    Hi there,

    I am sorry but the problem is not solved. when I try to show the file in an item in the library I got error: file not found... If i click on find file it is pointing inside the storage folder, in another folder that has been created called storage... for sure that one is empty (i never created it)... so this is the situation: Zotero (folder)\Storage (folder copied from old one)\storage folder (empty, created by zotero?). If i try to copy all the item from main storage folder to the one created by zotero... i still get the same error 9file not found). Ok so i guess there s a mess with sqlite files and storage folder...

    Where could be the right position of all these files? I mean in the zotero standalone on old pc, the sqlite files (the main + baks) are stored in the main folder (zotero folder) at the same "level" of storage folder. On the new pc, every time I start zotero the sqlite files are stored in zotero\Storage folder... so 1 level deeper...

    any suggestion, plz?

    Thank you
  • edited February 13, 2013
    The Zotero data page explains the file structure. It sounds like you've been setting the 'storage' directory as your data directory. They're not the same.
Sign In or Register to comment.