Report id: 1773498276. Error first file syncing with WebDAV server

Hi all,

I am using zotero portable on windows 98 with a chrome plugin. Today I decided to sync (for the first time) all my library with some WebDAV server (i.e. 4shared) and after few minutes I got the red symbol close to the sync button telling me that a WebDAV file sync error occurred. On the server the zotero folder (that i previously created from the site)stays empty . I tried again with manual sync but I got the same error. I tried to install a new version of portable zotero and I tried to change the WebDAV server, but I got no any good news.
any idea please?
thank you
  • just to get versions clear - by "portable" Zotero you mean Zotero Standalone, correct?
    And you're presumably using Windows 8 and not Windows 98?

    Typically this is a webDAV problem and you'll have to report this to your provider, if you provide a debug output ID: for a manual sync attempt, Dan will likely be able to tell you what error specifically to report to your webDAV provider.
  • Hi adam,

    thanks for your reply. Yes with portable I meant Zotero Standalone and no it is not windows 8 but windows xp (I am sorry for that but my t9 on mobile decided to change xp to windows 98 :P ). Anyway, I am not so sure the problem should be related to the webserver because as i said i tried a couple of different Webdav servers:

    I tried 4shared;
    ERROR: D1795062482.
    I used google drive using Otixo as webdav server following this instruction: ;

    I used cloudme following this instruction
    (ERROR: Webdav server did not accept your username or password)

    any help?

    thank you
  • edited February 7, 2013
    I got cloudme working (i mean, clicking verify settings in zotero options it tells me everything is right), following this:

    but when I click on manual sync i still get the error: 831779512

    So now I have 3 diffent servers giving me the same error

    thank you
  • [JavaScript Error: "[Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIFile.fileSize]" nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)" location: "JS frame :: chrome://zotero/content/xpcom/attachments.js :: :: line 1103" data: no]" {file: "chrome://zotero/content/xpcom/storage/webdav.js" line: 772}]
    Take a look in the 'TAI48P5U' directory within the 'storage' directory within your Zotero data directory. Do you see anything out of the ordinary? We've seen this before when a Windows alias (.lnk) has ended up in a storage directory. It could also possibly happen with a very long filename.
  • Hi Dan,

    thank you for your ans. I checked that folder, there was a normal pdf file and a very strange one. The name was very long, and I was not able to select it or to delete it. I delete the entire folder from zotero and I create a new item in the library using the normal pdf. Everything worked nice. Thank you.
    But here comes another problem. It is taking ages to submit all my items to WebDAV server (I am using 4shared). After 1 day I just uploaded 78 MB (all my library is around 2.8 GB!). I am using a University server, so I do no think the problem could be related to the speed of my connection. I switched on the debug, I start to sync and submitted the debug this morning (during all night I uploaded something like.. 10 MB!).
    The Debug ID is D1294118901.

    any idea what is happening?
    I read 4shared is working fine with zotero, so I do not understand the problem. Otherwise can anyone suggest another webDav server with at least 5GB of space?
    thank you
  • edited February 9, 2013
    There's something extremely wrong with your uploads:

    (3)(+0000001): HTTP PUT '<properties version="1">
    </properties>' to https://****:****

    (5)(+0353097): Beginning DB transaction

    The +0353097 there indicates that nothing happened for almost 6 minutes after Zotero tried to PUT a small text file on the server, and the same thing happened for many other files. That's likely an issue with your network or with your WebDAV provider (or something on your computer).
Sign In or Register to comment.