problem with the SUDOC translator


I'm working with Zotero 3.0.11 addon for Firefox and I'm having some troubles with the SUDOC (French Academic Libraries catalogue) translator. Instead of showing me the blue book it sometimes has the yellow file normally used for multi-import (for example here :
When clicking on the yellow file a window opens and shows two possibilities of recording the item, with the same name. I tried both and it does not import correctly all the data : authors, editors and place are missing.

I did not see any other complaints about this translator (I mean recently, because I noticed in the discussions that the Sudoc had changed system, maybe last year, and that the translator needed some important changes), but I'm using it a lot, and I think it would be helpful to many people if someone could fix that.

Thank you,

  • Can you paste here the "Identifiant pérenne de la notice"?
  • edited January 30, 2013
    Here it is (sorry) :

    And it works when I click on the link : good to know, I hadn't thought about doing that.
  • Uhm. I can't reproduce your issue with this link... but the translator doesn't work -exactly as you described- in other cases. What was your search word?
  • I searched "Kallimachos in Rom" and clicked on the second entry (corresponding to the book I was looking for).
    In order to have the blue book I have to click on the "identifiant pérenne de la notice".

    But you're right, it does that practically with all other books in the Sudoc.
  • This is caused by the double slash in the URL that you posted originally (i.e. SUDOC translator does not recognize this. This causes the COinS translator to kick in, which recognizes some (two sets of) metadata embedded in the page (but it's not that great). If you hover the mouse of over the folder/collection icon, you will see which translator is being used. We'll push a fix for this soon. In the mean time, using the stable URL should work. Also removing the extra slash will do the trick.
  • edited January 30, 2013
    Étrangement c'est le translator COinS qui est utilisé dans certains cas... aurimasv ou adamsmith doivent avoir une idée de ce qu'il se passe.
    Édition: cf. message d'aurimas au-dessus!
  • Thank you. When I remove the extra slash in the URL the translator PICA can work (instead of COinS with the double slash).
  • I just pushed out an update for this (thanks to symac for the actual fix). You can wait for your translators to update automatically within 24 hours or update manually via Preferences... -> General -> Update Now
  • Thank you very much for your help !
  • Bonjour,
    c'était bien ce double slash qui posait problème, apparu récemment dans le cadre d'une mise à jour côté sudoc.

    Si vous rencontrez d'autres problèmes avec ce connecteur à l'avenir n'hésitez pas à poster à nouveau un message sur le forum.
  • Bonsoir,

    Merci beaucoup. Je n'hésiterai pas à poster un message s'il y a de nouveau un problème. Je tiens en tout cas à dire que je suis très admirative de la réactivité de toutes les personnes qui ont répondu aux différents problèmes que j'ai eu récemment avec des traducteurs de Zotero !
  • Hello,

    although I read here that the SUDOC issue has been fixed, it still doesn't work for me.
    When I go to Sudoc (e.g., I do have a blue book, but when I click on it I get "Saving Item… An error occurred while saving this item. Check Known Translator Issues for more information."
    I use Zotero Standalone on a Ubuntu 12.10 distro with Chromium. I've checked that my translator is up-to-date. The error happens whether zotero standalone is launched or not. However, I just figured out that with Firefox, everything works smoothly.

    Thanks a lot to all those helping here!
  • [JavaScript Error: "Object function () {
    var args = (passAsFirstArgument ? [passAsFirstArgument] : []);
    for(var i=0; i<arguments.length; i++) {

    return fn.apply(object, args);
    } has no method 'cleanISBN'" {file: "eval at <anonymous> (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/inject/translate_inject.js:50:9), <anonymous>" line: 452}]

    I can confirm that. This looks like the connector can't use the cleanISBN function?
  • edited February 4, 2013
    The Chrome and Safari connectors were not updated since 3.0.8, but cleanISBN was introduced in 3.0.9. We messed up when updating the translator by not marking it minVersion 3.0.9

    This is definitely going to be fixed with 3.0.12, but in the mean time we might want to undo the cleanISBN changes. and push out a 3.0 compatible translator. Then redo cleanISBN with proper minVersion

    Edit: sorry, by "we messed up" I mean "I messed up"
  • This should be fixed in the latest translator.

    (with connectors, how do translator updates work? Are they sync'ed with Standalone? Do you need to update connector translators manually via connector Options -> Advanced -> Update Translators?)
  • (with connectors, how do translator updates work? Are they sync'ed with Standalone? Do you need to update connector translators manually via connector Options -> Advanced -> Update Translators?)
    maybe I'm missing something (as I'm pretty sure you know this), but they update exactly as they do for Zotero for Firefox: Zotero Standalone phones home once a day and updates translators or you can get the updates automatically from the general tab of the Zotero preferences. The connectors use the translators in the Zotero data directory.
  • Zotero connectors have direct access to the Zotero data directory?

    Also, in case where a connector is used without ZSA (i.e. directly with there is no zotero data directory... or is there?
  • edited February 4, 2013
    yes they do - I just tried this out - modify translator (marked as Chrome compatible) in scaffold for Firefox, safe, use Chrome connector with http.server enabled to import and the changes are present.

    If used directly with server without ZSA I don't know - doesn't translation always happen server side, then?
  • Hello,

    I still have the problem describe by Julie Damaggio in her first post!
    I update the translator manually (Preferences... -> General -> Update Now )
    I have the double slash, even when i remove it zotero want to use COinS.
    I have Firefox 19 and Zotero 3.0.11. Shall i passe to the 3.0.12 version?

    Thank you,
  • I have Firefox 19 and Zotero 3.0.11. Shall i passe to the 3.0.12 version?
    Firefox 19 is currently still in beta. Generally speaking, Zotero may be broken in beta versions of Firefox (though this is not exactly the reason here).

    It turns out that SUDOC is serving pages with a different URL to Firefox 19. They added an "/xslt" part (e.g., which was not being recognized by the current translator. I fixed the translator, so update and try again.
  • edited February 6, 2013
    Perfect! how reactive!

    Zotero is now working on sudoc with Firefox 19 :)
    Thank you
Sign In or Register to comment.