Zotero Standalone 3.0.9+ require Mac OS X 10.6.3 or newer

Hi, I use mac. I got a Zotero standalone update request while I was using it. As the info suggests, I closed my Zotero standalone. I saw the updating process, but while I tried to open it again, Zotero standalone couldn't be open any more.
A yellow triangle with an exclamatory mark in the middle saying that:

The application zotero-bin quit unexpectedly.
Mac OS X and other applications are not affected.

Click Realaunch to launch the application again. Click Report to see more details or send a report to Apple.

Any suggestions will be highly appreciated!
  • edited September 1, 2013
    Do you remember what version it updated you to?

    Try dragging Zotero from your Applications folder to the trash and reinstalling Standalone from zotero.org. You may have been among a very small number of OS X users who received a broken update due to a Mozilla bug.

    See below.
  • Dan, thanks for the suggestion. I tried, however it still fails to open. the same message came up again, saying:

    The application zotero-bin quit unexpectedly.
    Mac OS X and other applications are not affected.

    Click Realaunch to launch the application again. Click Report to see more details or send a report to Apple.

    The version i update was Zotero-
  • What version of Mac OS X do you have?
  • I am also having this exact problem, which also occurred after accepting an update request. (Too bad I need to take my qualifying exams tomorrow and wanted to organize my lists beforehand! This is so typically my luck.) I tried restarting my computer. I also tried re-installing the app. I am also a Mac OS X 10.5.8 user. More specifically, the error report says:

    Process: zotero-bin [583]
    Path: /Applications/Zotero.app/Contents/MacOS/zotero-bin
    Identifier: zotero-bin
    Version: ??? (???)
    Code Type: X86-64 (Native)
    Parent Process: bash [579]

    Interval Since Last Report: 115 sec
    Crashes Since Last Report: 1
    Per-App Interval Since Last Report: 0 sec
    Per-App Crashes Since Last Report: 1

    Date/Time: 2012-11-25 19:49:39.104 -0600
    OS Version: Mac OS X 10.5.8 (9L31a)
    Report Version: 6
    Anonymous UUID: 71BE0CE7-3BB3-411B-BE34-6E4241ADE24A

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    unknown required load command 0x80000022
  • edited December 13, 2012
    As of 3.0.10, Zotero Standalone no longer works with OS X 10.5 (Leopard). (Firefox 17 also drops support for 10.5, and Zotero Standalone is based on the same code as Firefox 17.)

    For an immediate fix, you can re-download Zotero here: http://download.zotero.org/standalone/

    Longer-term, you should upgrade to 10.6 or later. (You can get Snow Leopard for $20, and then if you want upgrade to Mountain Lion from there.) The major web browsers are no longer being updated for 10.5, so it's not really safe any longer to use 10.5 for web browsing. This is also the only way to continue to use the latest versions of Zotero Standalone.
  • edited November 26, 2012
    Thanks for the help, Dan. I suspected this was the problem. Other apps have been giving me the cold shoulder in the last few months.
  • Thank you!!! I just posted this exact same problem without looking at other threads - stupid I know.

    So relieved!!
  • life saver!!! thanks for that I was freaking out!!
  • @Dan Stillman: Which bug is/was causing this? I am building from source and experiencing the same issue.
  • edited December 3, 2012
    This is caused by XULRunner 17 being incompatible with Mac OS X 10.5.
  • Thank you! I should upgrade my OS, of course, but it's good to experiment with this older version of Zotero for now. Thanks again!
  • Thank you this was my issue as well. Running 10.5.8. Frustrating because this laptop is only just over three years old and Apple is no longer releasing updates. Subsequently, running into a lot of issues with applications. Pay more for less I guess.
  • Ghant: Snow Leopard (10.6) came out in August 2009, so any Mac released since then should have had it or been able to upgrade to it for free. It sounds like perhaps you just missed the cut-off, but you can upgrade to Snow Leopard, which runs on any Intel Mac, for $20. The last PowerPC Mac (the only ones that can't run Snow Leopard) came out in 2006.
  • (Actually, anyone who bought a Mac with 10.5 after June 8, 2009, was able to upgrade to Snow Leopard for $10. It was $29 new.)
  • Hi Dan,

    If I install Zotero again using the link you provided in the Nov 25th message, will this affect my existing Zotero library?

  • while you should always keep a back-up, no, re-installing Zotero will not delete your old library.
This discussion has been closed.