"Chicago No Ibid style" resulted in everything treated as 2nd ref

The journal to which I'm submitting doesn't allow ibids., so I downloaded the Chicago Full Note/No Ibid from the repository. While it did indeed get rid of the Ibids (well, all but one), it also changed ALL of the regular citations to be as if they were the second/shorter versions. That's what you replace Ibid with, but all of my first-references have their first names, publishers, dates, etc. stripped out! It also stripped out all of the html information from citations for web documents or online journals, which I think is probably stripped out of second references, but shouldn't be for first.

Meanwhile, I can't seem to edit the citations, either! It tells me to put my cursor in the footnote, which I do, but I get the honk and a signal telling me the action isn't allowed. So I can't win! With some luck, closing down FF and Word and restarting will at least let me edit, but I'd tried that earlier for the install and it didn't help the primary problem.
  • The style should be fine. Could you try it in a new document?
    Nothing big - just insert the same citation twice and see if the footnotes look right.
  • Ahh...if only everything that SHOULD be fine actually were ;-)

    So I just closed and relaunched both Word & Firefox, started a new doc, and the first footnote showed up as a second ref. Second footnote to same ref at least didn't show up as ibid, but still no first name or gory details...

    I noticed the preferences show: Chicago Manual of Style (note without bibliography, no Ibid.)(LEGACY) (not capped.) Could the legacy be an issue? I have Word 07, FF 15.0.1 and just a few days ago re-installed the Word plug-in, using the latest, as I wasn't seeing the Zotero toolbar at the bottom of my Word docs, which fixed THAT problem...

    It does let me edit the citation in the new doc. So I called up the doc with the 80 footnotes I need to submit for publication, but it still won't let me edit cites. Gives me the x and tells me "You must place the cursor in a Zotero citation to edit it."

    Thanks for any help!
  • So two issues -
    the first one is very simple: You're just using the wrong citation style. You wrote "Full Note, no ibid." in your first post, but it looks like you're using (Note, no ibid.), which will, by design, do exactly what you describe. Install Full Note, no ibid from the repository.

    Once that's fixed, the inability to edit is a bit more misterious:
    Try inserting a bibliography in your longer document and see if that works (regardless of whether you're going to need that in the end).

    If that works, it might make sense to see if 2 and 3 here help:
  • Oh happy day! That appears to have been the problem and restored the full cites!

    Editing-wize, that appears to be working as well! BUT, this is my first experience with Zotero at all, as well as trying to edit, and I'm really thrown by the warning at the bottom of the editing page: Warning: If you edit a citation in the editor it will no longer update to reflect changes in your database or the citation style?????

    The journal to which I'm submitted has a few other quirks as well, so I will need to edit the cites, but don't want to wreck the ability to change styles or not reflect new references and such. As you know, it's rare as hell to get accepted without some revisions. And I also may get rejected and have to go to a journal with a different citation style. (Hate to even type that for bad luck!) What's up with that?

    Again, THANKS!
  • Ideally, of course, we'd want a style for the journal

    Since Zotero 3.0 you're able to just edit in Word, not using the Show Editor, which is quirky anyway.
  • Also, just combed through the footnotes and see some weird symbols in what should be normal titles. (I also noticed it's only showing up for web references.: Where the title of the website is, I'm getting left arrows followed by the outline of a small square. (Arrows show up on a copy/paste but not the square.) I can eliminate it in the editor, but again there's that scary warning!
    About « 1 for All:
  • So if I just go in and make tweaks in Word I won't kill Zotero's basic ability to let me add in a footnote or a reference to my library and have it renumber everything, keep track of first/second refs, etc? (Which I sooo love about Z!) That warning scared me!
  • edited September 14, 2012
    could you take a screenshot of this and post it to a free image hosting site and post it here?
    So if I just go in and make tweaks in Word I won't kill Zotero's basic ability to let me add in a footnote or a reference to my library and have it renumber everything, keep track of first/second refs, etc?
    no - it will ask you what to do when you change styles.
  • How about I turn it into a PDF? Will that work?
  • Turning a doc into a PDF is no different from printing it - has no impact on Zotero at all.
  • Think I figured out what's up with the arrows at least. I checked the original citation entries in my Zotero library, and the >> are getting captured in the TITLE info. And indeed, when I go to the links for the websites in question, under the fancy graphic headline, there's a line that says:
    1 for All > YouTube contest

    Interestingly, it's showing up in the Info box/Title as reversed:
    YouTube Contest<<1 for All, but I don't suppose that matters.

    The little square shows up there, before the arrows, and once in a regular book citation, in the title, before a colon:

    There are just a few, total, so easy enough to edit out. (Now that I can edit without freaking out!)

    I looked into trying to edit the style to match the journal with the CSL editor, but i am a total novice code-wize, and think it'll just be easier to change the "date accessed" info, which is the main difference from what Zotero has produced for me.

    Can't thank you enough! (I've paypal'd you all a couple of times over the course of this paper, but think you're due another pop!)
Sign In or Register to comment.