Inserting citation with LibreOffice plugin takes 20-30 minutes...


Recently, adding a new citation to a document in with the Zotero LibreOfice integration plugin began taking an inordinately long amount of time (about 20-30 minutes), and a lot of system resources as well. Some pertinent information: I'm using Ubuntu 11.04, and Zotero standalone (although I've also tried it through Firefox). This occurred in a document that I've been working in for several months with no troubles (it's a dissertation chapter), and have never had this problem before on my system. This problem seems to have started after the latest LibreOffice and Firefox updates (updated at the approximately the same time through the Ubuntu autoupdate feature). I have tried deleting the bibliography (as was suggested in some old threads as a solution for increased insertion time), but to no avail. I have tried also using the old style in-text citation editor (instead of the "quick format citation" editor), but to no avail either. I am able to find the citation I want to insert using either of the intext citation editors, but when I click to insert it, it cycles a bit, and then appears to freeze for a long time (but the processor is still maxed out), and if I am patient enough to wait, the citation may be inserted after 20-30 minutes time. I am able to stop the insertion process by clicking the "x", and although the citation is not inserted, there is a greyed out field with the text {Citation} in it. I can delete this field if I want to.

Now here's the kicker. This ONLY happens with this particular document! I'm able to insert citations as normal in any other LibreOffice doc. This is a very important document, and I don't want to loose any of the citations that are in there (there are a lot). Does anybody have any suggestions for me as to what I might do to save this doc?

  • run through these, good chance that will help:
  • Thank you for the link! I will try these options now and report back....
  • Well, I went through each of the steps and was not able to isolate a particular problem citation... There was an error generated, however, which I sent as error report 539609315. Any extra help that can be provided will be greatly appreciated...
  • I think this is the relevant error:

    [JavaScript Error: "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIServerSocket.init]" {file: "file:///home/iullah/Desktop/Software_installer_packages/Zotero_linux-x86_64/extensions/" line: 83}]

    should I attempt to reinstall Zotero standalone and/or the LibreOffice integration plugin?
  • Actually, scratch that. I was able to get citations working again by deleting the whole section I've been working on. It's right in the middle of the doc, so when I tried troubleshooting tip number 8 (Delete half of the document at a time), I must have still had a bad citation in each half. I will now begin going though the section paragraph by paragraph until I find the bad citation.Thanks much!
  • Just a final report back to say that I was able to isolate the two bad citations and remove them. I've been able to resume working with the document, and all is right with the world again! Any idea what might have "broken" the two citations? I was able to add them back, everything still works... It would be good to know if there is something specific I did that "broke" them so I can avoid repeating this mistake in future...
  • Do you have a copy of the document in its original, broken state? If you can edit it down to just those two bad citations and send it to, we'll take a look.
  • I do, I can, and I will do so now. I'll refer to this thread in the title of the e-mail.

    Cheers, and thanks for all the help!
  • I want to post a quick follow up, as I believe I figured out the root cause of the problem I was experiencing. I believe the error occurred when I cut and past a line of text containing an active zotero citation from the body of the text into a footnote. I'm using LibreOffice 3.3.4 on Ubuntu, and using LibreOffice's built-in footnoting (Insert>Footnote/Endnote) and choosing "automatic numbering". I believe that the zotero citation (I use reference marks, not bookmarks) became corrupted during this copy and paste. Deleting the existing footnote, reinserting a new footnote, and THEN inserting a new zotero citation in the footnote works just fine. It's only when cutting and pasting a sentence with an existing citation into a footnote that causes the error. In both cases in the document, the reference fields were altered so that only the space right after the closing parentheses was "grey", but the rest of the citation was not. I know that I DID cut and past the sentences into those two footnotes, and I know that deleting them and reinserting them from scratch DID solve the problem, but I was NOT able to replicate the problem by repeating the cut and paste procedure. This error may thus be a very specific one. My main point in posting here is to help anyone one else who may come across this same issue in the future...
  • Hi isaacullah and others

    I just encountered precisely the same problem.

    Inserting citations took a loong time in a large thesis document, perhaps 5-10minutes with firefox taking 100% processor power. In other document everything worked fine.

    The problem was the same as described by isaacullah:

    In a footnote on a random page "the reference fields were altered so that only the space right after the closing parentheses was "grey", but the rest of the citation was not"

    Removing and recreating the footnote solved the problem.
  • I'm glad this helped! Yes, I am now 100% sure that the problem occurs whith citations in footnotes. What is strange is that it's not EVERY citation in a footnote that will cause this error. It's only certain ones. I *think* (but can't be sure) the error happens when you copy and paste a citation out of the text body and into a footnote. That seemed to be the case for the ones I found in my document, so I'm willing to bet that that's what causes it. It's the only thing that makes sense to me, anyway. In any case, the issue is solved by reinserting the footnote WITHOUT the citation, and then adding it in from scratch (i.e., with the "insert citation" tool).
  • Back again to say that the problem keeps comming up from time to time in my large document.

    But I have now discovered a clever way of identifying the broken citation.

    LibreOffice Navigator (press F5) has a section called References which will hint you the broken citation when trying to insert a new one.

    See a small guide with screenshot here:
  • Thanks for sharing that! Yes, I still have this error from time to time (also in a large thesis file, into which I am now inserting revisions). This trick seems like it will make troubleshooting MUCH easier! The hardest part is to find the troublesome citation, and this is a very clever way to do so. Thanks!
Sign In or Register to comment.