retrieving metadata for pdfs

Hello all, I have been unable to import any pdfs and retrieve the metadata for them -- or even index them for that matter. I have the most up to date zotero installation (both for firefox and the standalone) and the most up to date pdf indexer. I have tried a variety of publisher-created pdfs.

Can anyone tell me what's going on? has this function stopped working?
  • Provide an example of such a PDF and we'll take a look.
  • try this one from pubmed:
  • Works fine for me. What's the problem, exactly?

    Provide a Debug ID for a Retrieve Metadata attempt that fails.
  • Here you go. Thanks.
    The Debug ID is D277704712
  • I'm confused by this debug output. This appears to primarily show the saving of the attachment, not just a Retrieve Metadata attempt, though that's in there too in the middle of the save.

    But the primary problem seems to be that the PDF isn't being indexed. If you click on the green arrows next to "Indexed" in the right-hand pane while viewing the attachment, does it change from "No" to "Yes"?

    Are you running any security software on your system?

    If you delete pdfinfo* and pdftotext* from your Zotero data directory, restart Firefox, and reinstall the PDF tools from the Export pane of the Zotero preferences, does that help?
  • Clicking on the green arrows next to indexed in the attachment pane did not work.

    So I deleted the pdfinfo and pdftotext in the data directory, reinstalled them, tested it and it worked. Thanks!
Sign In or Register to comment.