Word plugin in track change mode: Field Code Changed

I have a little issue that may be deemed as a feature request. Every time I add or change a citation within a Word file, Track changes label *every* reference with a "Field Code Changed" by Unknown User. This is a harmless thing, and I have observed no issues working with Zotero in Word while Track Changes is turned on (despite warnings for earlier versions of the Zotero plugin). However, with many many references in some of these files, these are becoming quite an annoyance, especially when I am hoping to convert my fellow co-workers from EndNote, who all heavily depend on Track Changes and reference manager software.

Is there a way to avoid Track Changes messages for citations that are not modified?
  • Are you using a numbered citation style? If not, adding a citation shouldn't change every field's field code, and if it does, that's a bug. If so, making a change to your document that changes the citation numbers will label every field. We could disable track changes when updating field codes, which would avoid this message, but it wouldn't be possible to revert changes to citations using tracked changes. I'm not entirely sure that this would be preferable.
  • Nope, I am not using a numbered citation style.

    However, after some testing I realized I observe this phenomenon sometimes only. It may have to do with inserting new citations for previously cited items which triggers this, or using Mac Word in 2008 compatibility mode. I will get back if I can pin down when this happens reproducibly.
  • I have the same issue. It doesn't affect working within the document, it's just an annoyance to have so many extra tracked changes and comments. I'll keep an eye open here for any solutions.
  • Yes, I still have the same problem, and have not been able to pin down the exact circumstances. And yes, it is still an annoyance that I would love to see go away.
  • This annoyance has nothing to do with Zotero, rather it is caused by MS Word's "track changes" feature. It will only occur if you add a citation that has not already been cited in your document, which results in the citation numbers changing and causes word to identify these changes.

    How I avoid the issue is by turning off MS Word's track changes feature prior to adding a citation. If I forgot to do so and I ended up with a ton of "Field Code Changed" instances, I simply undo my last action, turn off track changes, then repeat my citation addition.

    Hope this helps
  • Thanks semeniuk for the suggestion.

    I did not think of this as a bug, but a feature request where Zotero could somehow fool Word not to change other fields' field code. And according to Simon, who is a Zotero developer, this should not be happening at all. But you confirm that it does.

    In my case, it happens only sometimes. I can't figure out the exact circumstances...
  • edited March 19, 2013
    My apologies for saying this has nothing to do with Zotero so quickly. It obviously does, otherwise, the issue would not have been posted in this forum.

    As I stated above, you should only notice this issue if you are adding a citation that has not been previously cited in your document. This is due to all future reference numbers increasing by one, which Word interprets as a change to the document. Since zotero's citation numbers are fields, this change is represented by a change to the field codes. I encounter the same issue due to an unrelated cause when I add or delete equations, which is also represented as a field code change.

    Again, I have found that turning of "track changes" in Word's review functionality right before adding a new citation then turning it back on after is the best/only solution for this annoyance.
  • Is there still no solution for this? Why don't we open a bug or a fix request. People that do not work with Zotero find this very annoying.
  • I'm encountering this problem right now. It doesn't happen consistently. In some documents, when Track Changes is on, adding a new citation causes 'field code changed' to be tracked on other citations. But in other documents, adding a new citation has no effect on other citations.

    Has anyone got to the bottom of why this occurs?
  • This for me isn't a small issue - it's a real game changer in whether I can write large documents using Zotero & Word...

    I posted a separate features request and was asked to keep this thread going instead. Really encourage others to chip-in their thoughts if this is a problem for them too.

    On the question of *why* it happens...
    - I think the major problem lies in introducing a new reference to a document when tracked changes are on. If you introduce a new one and delete another then the changes will cancel each other out and the problem is less likely to be seen...
  • In your post on another thread it appeared to me that you were complaining that when you entered a new reference (before the end of your document while using a numbered style such as Vancouver) and the reference numbers updated; you object to track changes marking the updated numbers being flagged as changes. Zotero will automatically update the manuscript to reflect the insertion of the new reference and the reference numbers will change. This change is a good thing.

    I suppose that you are sharing your document with a colleague or a supervisor. The way I handle this is to always share a copy of my working document that has all field codes removed. I turn on track changes in the copy I forward to my colleague. That way the colleague / supervisor can make changes and comments without affecting my original work and I can then easily see the comments and incorporate them into my working copy.

    Although I haven't verified this recently, this "problem" occurs with other bib management software (BMS) such as EndNote and Mandeley. The BMS is doing its job facilitating keeping track of citation number changes and the word processor is doing its job by marking the changes.

    All my remarks notwithstanding, if there is a way to avoid these changes being flagged, I would be pleased to have a way around this.
  • I also have this issue, though the number changes (field code change) are workable. What my zotero does is randomly add this -

    {ADDIN ZOTERO_ITEM CSL_CITATION {"citationID":"143koljv0e","properties":{"formattedCitation":"{

    Followed by about 1 page of text that spell out each new citation. If I try accept changes, the text stays there; if I try remove markup, the text remains. It is WAY more of a pain than the field code changes since I don't know if I delete this text whether or not it will mess up something with my citations.
  • Just accept the tracked change twice. What Word is doing is showing you the hidden field codes that Zotero changed. Simply look at the massive code as indicating "Zotero changed a reference".
  • (But track changes and field codes interact somewhat weirdly in Word. Field codes can be generally not shown, but if you are cycling through the tracked changes, Word will show one changes set of field codes at a time--showing you the changes codes for the highlighted field. Don't be alarmed, just click Accept twice to acccept the changed codes and continue as normal.)
  • I agree that this is NOT a minor bug/annoyance. I have to work with tracked documents all the time and remembering to switch track changes on and off continually is very difficult. This is the one bug that stops me from recommending Zotero to colleagues. Does anyone have a permanent solution? Could disabling track changes on Zotero updates in Word be an option that could be added to Zotero 5? That way people would have a choice.
  • (Please don’t post the same issue in multiple threads.)

    When field codes pop up, click Accept twice. That will hide the codes for that reference — this is just Word showing you that codes were change. You don’t have to turn off Track Changes. It really does work without any hassle.
  • I could not disagree more strongly!! Try doing "Accept twice" 2000 times, while skipping the changes you have intentionally made, not those made by Zotero. This is incredibly frustrating! Is there any way to make Zotero switch off track changes automatically?
  • edited September 25, 2017
    I wrote a 900 page dissertation, dozens of articles, and a 500 page book using Zotero. It is a quite fast habit to develop to quickly click accept twice when field codes pop up.

    That said, it is really difficult for any Word Add-in (Zotero, Endnote, Mendeley, etc.) to interact with track changes, because the controls for this have changed many times over the versions. This is even an issue for Word’s native (terrible) bibliography function and the Word “Compatibilty Mode” feature. The Zotero developers have and continue to look into ways to make it work more nicely with Track Changes, but it is a very difficult problem to solve (not least which because it’s not clear that disabling tracking is the desired behavior).

    You can use a Macro yourself to accept all tracked changes in Fields in one go (so your workflow would be to use this macro to accept field changes, then proceed with the rest of your review).
    http://www.msofficeforums.com/word/23330-how-get-track-changes-ignore-field-code.html
  • Yeah, I wrote my PhD thesis with Zotero and I believe at that time this issue had been already addressed. I believe this is a bug reintroduced recently.

    I appreciate that changes to word make this difficult for developers. That said I would view this as critical for many users (see the numerous threads on this issue in Zotero's forum). I appreciate the uncertainty of the Zotero team as to what the desired behavior is for users. But could that not be solved by giving this as an option in the settings, giving users the ability to choose which behavior they want and change their minds down the road if needed?

    I did numerous searches and tried the approach you suggested before originally posting. I created a new macro, pasted the code and then ran it on a 'corrupted' document. Nothing happened! I don't know if there is something I am missing or if this reflects another change in Word (solution is from/for 2010, I am running 2013/2016). If this was addressed with updated macro code on the Zotero website that would be a step in the right direction.
  • edited September 25, 2017
    This isn't an issue with "corrupted" documents. It is simply that Word is tracking changes to field codes. You can address this yourself by running the macro I linked above, which will accept all changes to field codes in your document. If that exact code doesn't work, you can try to google around for VBA code for Word 2016 that accept all track changes in field codes (e.g., perhaps this https://answers.microsoft.com/en-us/msoffice/forum/msoffice_word-msoffice_custom/how-to-remove-all-revisions-from-an-unknown-author/33c42bf7-c4fa-4f64-85be-ab86b1930c5a?auth=1). Let me know if you find something that works, and I will gladly add it to the Zotero wiki.

    Regarding whether this was "fixed" in the past, it used to be that Zotero documents could get easily corrupted with Track Changes on. This was fixed, but that never changed Word's default behavior to track changes to documents, including changes to field codes.
  • As stated above, I have already tried this. The macro does not work.

    I appreciate your explanation and suggestions, but this remains a critical issue for me and I believe many others.
Sign In or Register to comment.