Sync/preferences issues

My problem is most like this

but only as described in the post title; I'm not trying to use multiple data directories or anything.

I have a new installation on a Windows 8 Release Preview machine, running Firefox 13.0. I installed both the Firefox add-on and Standalone, and the problem I am having is common to both. Some but not all of my Zotero preferences are being saved, with the "sync automatically" preference remaining checked whatever I do. The attachment sync settings are also affected. As a result, both versions will start trying to sync immediately upon start-up. I'm not sure how this started, but at first things seemed normal. I'm not sure what went wrong, or when. I tried closing both, restarting, and deleting my Zotero data directory before restarting, but the issue persists. I can't generate an error report, because the applications both freeze up almost instantly, preventing me from doing anything.

My confusion is compounded by the fact that I never got syncing working correctly on the Windows 8 machine. It's an older netbook and a large database, so I expected it to be slow. Even so, I let the add-on run all night, but the sync never truly started. When I try to sync, both versions seem to hang on the "processing updated data from sync server" stage, resulting in an "application not responding" error from Windows. Today, everything is paralyzed.

Do you have any idea what might be causing all this? I am using a different computer to post this. It's not my main machine, and so not a disaster, but I'm out of ideas. I can try deleting and reinstalling Firefox, or whatever else might help. Thank you.
  • is there a chance this is just one large sync waiting to go through? I.e. have you waited for say, 15mins, with Firefox seemingly "frozen"?
  • There's always a chance, but I let it run all night, or about 12 hours, and again all this afternoon. When I look at the Zotero directory, it seems clear that nothing has been downloaded: the database file hasn't changed size from 24,500KB. My real database is over 105MB.
  • oh OK - nothing more than 1h freeze (and probably more like 10-15mins) is ever going to happen when things are working correctly.
  • MG6
    edited June 15, 2012
    I left it running while I waited for your answer, and it has now, suddenly, finished the sync. So, you were right on both counts. Even though it finally worked, I don't think it is working as intended. I skipped a couple of Windows versions (Vista and 7), but I've never seen Zotero act like this on XP or OSX. There was no visual indication of what it was doing, at all; as I said, it kept showing the initial update message for several hours. Also, it almost seems like the sync was running between sessions, but that must be impossible. I just don't know how the settings were locked like that.
  • that certainly sounds odd - but I understand correctly that you're good now? In that case I'd just treat this as a fluke and not worry about it - without the ability to replicate this it's not going to be possible to fix this.
  • Thank you. At least if it happens again, there's a record for the victim.
Sign In or Register to comment.