Note spell checking context menu doesn't work on my system

Fedora Linux/Firefox 11/Zotero add-on 3.0.3

Right click on a note window only display a Zotero context menu option, see print screen

I can only access the spellchecker and dictionaries from the HTML page, see print screen:

I could access the spellchecker and dictionaries menu yesterday, using the combo Ctrl+right click on the note menu. That does not work anymore. Possible reason:

My screen definition is 1400x1050 on a LCD 15', font size display is really tinny at this definition, I set the Firefox pref. font size minimum to 16 pt.
Zotero note font size was below 16 pt. when I could use Ctl+right click on note. I set Note font to 18, and Ctrl+right click does not work anymore. I don't try to revert back the note font size though.
  • edited April 26, 2012
    Spell checking isn't currently supported in notes (and never has been). There are a few contexts where it sort of works, but those are flukes.
  • this is contradictory information

    The words in note are underlined in red. When I right-click, I see the menu in the first print-screen.

    Could you develop?
  • edited April 27, 2012
    OK, actually I misspoke—spell checking worked years ago, before Zotero gained rich-text editing support, but it hasn't worked properly since then. That article was written back when Zotero had plain-text notes.

    We should be able to fix this at some point, though it may need to be through the spell checking functionality provided by TinyMCE, the rich-text note editor we use, rather than through the built-in Mozilla functionality.
  • I am reading most of the old thread related to spell checker on notes. I can see Dan Stillman addressing most of them. They apply to version 2.

    the kb link above is dated of Is it out of date with the current version 3.0.3?

    -Is it the recommended way to open the HTML editor to spell check notes/change FF dictionary?

    -Will the FF context menu be accessible in a future Zotero release?
  • Ops! cross-posts. Thank you for your answer.
Sign In or Register to comment.