Bibsys 2 - The blue zotero book icon is gone

In the new version of Bibsys there is no longer an option to save directly in zotero. They have options for EndNote and several others but not Zotero. I have asked them why, but they say they do not have the time to deal with this. Can Zotero swing the magic wand or is this something that has to be programmed within Bibsys?

The old version with the blue Zotero book:

The new version:
(This link requires one more click before you get access to the book in question...sorry about that)
  • Zotero _can_ do this, but it would be a bit of work. Do I understand correctly that there is no other view in the new bibsys than the one you link to? I see two items on that page - there is no different display for a single item, correct?
  • That is correct, there is no longer one specific page for each title. I guess that might be a problem for you?

    Anyway, as a librarian in an Upper secondary school we ,and other schools with us, teach Zotero to our students and they continue to use Zotero as they continue on to university. The blue book icon in Bibsys made us truly happy every day and we really don’t want to loose it:o(
    I do fear that this drawback in terms of user-friendliness will result in a switch to EndNote and that would be a real shame. We love Zotero<3 and our students as well, but I do fear that this bit of extra work will lead to less use of Zotero. So if you could try fix this in any way or be so kind as to contact Bibsys …that would be fantastic.år+du+det+på+maskina+di
    This is a link to the wiki we use when we teach our students Zotero... even though its in Norwegian you can se that we put a lot of effort in promoting Zotero:o)
  • edited April 25, 2012
    I'll let adamsmith comment on the feasibility of an updated translator, but even without it, keep in mind that those export options you mention refer to export formats, not programs. Zotero can import RIS data (which is what the "EndNote" and "Reference Manager" options produce) just fine, so if something can export to EndNote, it can export to Zotero. But by default Zotero should automatically import the data when you click on those links, and for some reason that's not happening. We'll look into why that's not working.

    In the meantime, as a workaround, if you save the exported file and drag it back into Firefox, you'll get an address bar icon to save it into Zotero. You can also use the Import option in the Actions (gear icon) menu as you would with any RIS file. Alternatively, if you have Zotero Standalone installed, you can also tell your browser to open the file directly in that to import it. These are obviously just temporary solutions until we fix the auto-import issue or someone manages to get the translator working again.
  • OK, I've fixed the issue that was preventing auto-import. (The site is specifying a rarely used content type for the RIS data, and Zotero's support for that type declaration was broken.) The fix will be in 3.0.4, which should be out very soon.

    In general, though, keep in mind that just about any site that exports bibliographic data can export to Zotero. At the worst (if neither one-click save nor auto-import is working), it's about the same as exporting into most other bibliographic programs.
  • Thank you so very much! Happy camper!
    "keep in mind that just about any site that exports bibliographic data can export to Zotero" Ok, if You say so....I am not that in to technical stuff:o)
  • Given that the workaround, well, works now, I'll push this back in the queue - I'm pretty sure this can done, but it's a complete re-write of the translator so it'll take some time.
  • Ok, I got a little bit confused as to when You will try to change this, but never mind me. I am very gratefull for your time and effort! Thanks:o)
  • Two different things - Dan has already fixed one issue and that fix will be in the next Zotero version:
    If you click on "import to Endnote" Zotero (starting in 3.0.4) will import the reference.

    The little blue book icon will take more work - I'll hope to do that eventually, but not anytime soon.
  • Update - I had a look at the bibsys catalog and it's such a mess that I won't be putting in the time to write a dedicated translator, sorry about that.
  • Bibsys has had another upgrade, so now the automatic import only works on some computers. They explained that it had something to do with how firefox handled RIS-files. It works on some computers, but not on the one used by our school.We can do automatic import from WorldCat, so this is totally beyond my grasp. Bibsys gave me this:
    <RDF:Description RDF:about="urn:mimetype:application/x-research-info-systems"
    NC:description="RIS Formatted File"

    BUT this is way to complicated for me and my students, so we have given up the entire Bibsys import:o(
  • I tried it out and his should just work using Zotero for Firefox - are you sure the option to "Automatically Import RIS/Refer" files is checked on the computers where it doesn't work? The mimetype - which is how Firefox/Zotero decide what to do with a RIS file - is certainly fine.
  • Yes, the "Automatically import Ris" is checked. I think the problem is that on our computers the whole mimetype text above is missing...Don`t ask me why. So we have to insert it ourselves to get the Bibsys import. Thats why they sent it to that I can copy it into the computer. That sounded logical until I discovered that we can do automatic import from WorldCat without the mimetype stuff above. There is probarbly some logical explanation to the problem, but its beyond me. And anyway I can not ask 800 students to copy and paste the mimetype stuff... way to complicated.
Sign In or Register to comment.