How to transfer attachments from private to group account

Over the past month, I've set up a private account and created a library for work with way more than the 100MB of free space allowed. I've shared my collections with colleagues, but obviously not all of the PDFs and other attachments are accessible.

We are now considering buying more space and sharing them from a team account so that all users can access the files, but the problem remains of transferring my very full collections (all with attachments) to this new account to be shared.

Is there an easy way of doing this, or do I need to start over?

  • Three steps
    1) Create a team account and buy storage space for that
    2) Create a group library with the team account
    3) Invite all team members to the group library
    4) Drag and drop stuff from the personal library to the group library

  • Thanks for replying, but I understand, in general, how to use a group account/library.

    The problem is that the many, many attachments which take up lots of space are currently in my PRIVATE account. Because of their size, only a small portion of them will sync when I try to transfer them to the GROUP account, once it is created. Therefore, other users will be unable to access those attachments from their computers.

    What I would like to do is avoid reattaching all the PDFs (which numbers in the hundreds) onto the group account when this has already been done once on my private account.
  • Because of their size, only a small portion of them will sync when I try to transfer them to the GROUP account, once it is created.
    What does this mean? Everything mronkko said was correct.
  • You can drag attachments from my library to a group library even if your my library was not synced completely with Zotero.
  • Not sure where I'm being unclear...

    I have a private account with no storage upgrade. While Zotero will sync ALL of the raw reference data (titles, authors, URLS etc) in a group library, it only syncs up to 100MB of attachments/stored copies, like PDFs or webpages, which end up being quite bulky, and far exceed the 100MB allowed.

    For example, if I were to access my account from a different computer, I would only be able to access the first 100MB of attachments that syncs (unless I buy add'l storage of course).

    So, because the files are stored on my personal hard drive, my account will block more than 100MB of being shared. Even if a separate group account is created with sufficient storage space, the problem lies in syncing the ATTACHMENTS from my private account so that others can also access them.

    The obvious solution, to me, is to reattach everything from the group account, but that is quite a time-intensive process and a bit like reinventing the wheel, so I would like to avoid that.
  • dmiller11: It does not work like that. Just follow the instructions that I provided.

    If you drag an item from My Library to a group library on your computer, the files do not go through your Zotero storage, but will sync directly to the group storage. If that group is owned by an account that has enough space, there will be no problems.
  • It's possible you'll need to disable syncing of "My Library" files—which is a separate checkbox from group file syncing in the Sync pane of the prefs—to avoid the quota error for your personal library, but otherwise you just need to drag the collections to a group with enough storage space and sync.

    (This assumes you don't have files in other groups that you're the owner of. If you do, the quota error for those might also interrupt the uploading process, in which case you'll need to make sure you're not over quota with files from those groups. You can also purge your online "My Library" storage from the website settings, which doesn't affect your local files but will free up more storage space for any groups you're the owner of.)

    A future version of Zotero will support per-library syncing, which should help ensure that quota errors from one library don't interfere with syncing of files in another.
  • Okay, I suppose I misunderstood from the start.

    Thanks for your help!
Sign In or Register to comment.