Word plugin inserts superfluous linebreaks in bibliography

I vaguely remember someone reporting the same problem, but an extensive search didn't locate that topic here, so I'm posting it anew.

The bibliography created by the Word plugin (newest version, using it with Word 2003) contains an unneeded linebreak after every reference. (When showing paragraph breaks ΒΆ, there are indeed two of them where it should be just one after every citation.)
Where does that come from and how can I get rid of it?
  • I can't find any solution this problem, which is quite frustrating actually. It prevents the refreshing of the bibliography, since I have to delete the line breaks each time. This doesn't seem to be in the CSL files, rather it is a problem with the template used by the plugin. I was trying to figure out how to easily edit the Visual Basic to fix this. Any ideas? Maybe I will post this on the Trac.
  • Actually it seems the problem is in Zotero itself: "Create Bibliography from Selected Items..." has the same problem -- it includes extra line breaks.
  • Oh I guess I can't create a ticket in Trac. But it would be great if someone else would please. This seems like a really simple fix, and would be very helpful. I'm surprised this hasn't come up before.
  • What style are you using? I just created a bib with the "Create Bibliography From Selected Items" function using Chicago and it worked just fine. If I can duplicate the issue I would be more than happy to write up a ticket.
  • It is a problem with all styles I have tried, including the Chicago styles. Maybe I haven't been clear about the problem. The issue is that there are two lines breaks between the end of one entry and the next entry, while there should only be one.

    Here is what the output for three items looks like now (Chicago style, Zotero 1.0.3):
    Turner, JC, M.A. Hogg, P.J. Oakes, S.D. Reicher, and M.S. Wetherell. 1987. Rediscovering the social group: a self-categorization theory. Oxford: Blackwell.

    Vermazen, B. 1982. General beliefs and the principle of charity. Philosophical Studies 42, no. 1:111-118.

    Vermazen, B. 1983. The Intelligibility of Massive Error. The Philosophical Quarterly 33, no. 130:69-74.

    Here is what it should look like:
    Turner, JC, M.A. Hogg, P.J. Oakes, S.D. Reicher, and M.S. Wetherell. 1987. Rediscovering the social group: a self-categorization theory. Oxford: Blackwell.
    Vermazen, B. 1982. General beliefs and the principle of charity. Philosophical Studies 42, no. 1:111-118.
    Vermazen, B. 1983. The Intelligibility of Massive Error. The Philosophical Quarterly 33, no. 130:69-74.
  • Thanks!

    Looking at the ticket, I see that there is still some doubt (from simon) about this being a general bug.

    No matter the desired style, line spacing should not be controlled through adding extra line breaks, but by controlling the presentation. That is, the second line break should be removed for all styles, not just Chicago. And in fact, the CSL files are unable to turn off these extra line breaks because Zotero always puts them in. I've verified this problem with Chicago, APA, IEEE, and MLA. And I've looked at the CSL to determine that this is out of its control as far as I can tell (or I would just make at style that fixes this).

    I appreciate the interest and (future) fix. As is, one has to manually remove the line breaks each time the bibliography is updated, so this will be a major improvement to the Zotero workflow.
  • edited April 8, 2008
    To have no extra lines, you need to add the following option to your bibliography layout: <option name="entry-spacing" value="0"/>

    This is now done in all Chicago styles--you can download from the Dev Styles section at http://www.zotero.org/styles/ Chicago note styles will only work with the dev xpi and the upcoming 1.0.4 version.
  • edited April 8, 2008
    Just for reference, here is the earlier thread about the same problem. Glad to see this will be fixed in future versions.
  • mark - The other thread refers to a different problem. APA and MLA do require an extra break between bibliography entries, so I didn't change anything in those styles. The question of using "entry-spacing" settings vs Word styles in the other thread is still open.
  • Ah, I see. Then it's good that I started this one after all.
  • edited April 24, 2008
    The APA style for the reference list is double spaced with no extra line between references (refer APA Publication Manual, 5th ed, p.313 for an example).

    Currently the reference list is appended by Zotero using a forced single spacing and a blank line. If this is being changed, then can the extra lines be removed and can the formatting be left to the current Word style? I have a style in Word set up for references, but the single-spacing is appended to this style and overrides the current double spacing.
  • Thanks for clearing this up.

    However, I don't see why all the styles shouldn't have entry-spacing set to 0. The exact spacing requirements can be set in Word, LaTeX, or whatever the bibliography is being imported into.
  • @eckles: because there's a difference between "can" and "must." If you don't set the spacing in the CSL style and have Zotero (or other implementations) pass on that information, then users are required to set it themselves, and the formatting doesn't work correctly otherwise.

    The challenge is just to achieve some balance.
  • edited May 7, 2008
    Placing the following lines into my local APA style csl solves this problem:

    <option name="entry-spacing" value="0"/>
    <option name="line-spacing" value="2"/>

    I'm still not sure why this isn't standard, but what the hey! I've had a crash course in csl and it didn't hurt too much. I've also created myself a second APA style which turns off the issue number and doi: or access details. Creates a nicer (though slightly nonstandard) reference list, as required by my current university markers.

    The latest dev version has solved all of the other issues I've reported in the forums with the APA style, except for the double spacing. C'est la vie.
  • I don't understand the term csl. Can I enter the information on my own, or do I need a particular program? Where is the file where I can place the
    "<option name="entry-spacing" value="0"/>
    <option name="line-spacing" value="2"/> lines?
  • Andersunz, you can find more background information on this here (style repository) and more specifically here (creating citation styles).

    You could ask tonyc2001 to send you his customized style, or you can apply the change yourself. It's probably easiest to get at the APA CSL file (which is XML data) through Zotero's built-in CSL preview tool. Type chrome://zotero/content/tools/csledit.xul in your adress bar and hit go. Then you can select the style you want to change in the dropdown pane on the right. The two lines must be added right below the <bibliography> tag of the CSL code in the upper pane (scroll down, it's towards the end). You might want to change the name of the style (in the upper regions of the CSL code) to reflect that it is your customized version of APA.

    Use the preview function to see whether it looks fine (select a couple of refs in your library and click refresh if you don't get a preview) and if it does, copy the CSL code from the upper pane into a plain text file (e.g. via Notepad). Save or rename the file as whatever.csl (the extension is important) and drag and drop it onto Firefox. Zotero will pop the question whether you want to install the style. OK it and you're done.
  • I'm happy to send you my updated csl file, just let me know how. As Mark points out you can save these somewhere with the filetype of .csl and then drag and drop them onto the firefox window and they will update the existing style.

    I also have another style which is APA without the issue number and access info (DOI). This is the one I use for assignments.

  • Tony-
    I would love a copy of your updated csl file for APA style. I am csl illiterate but I really want to get rid of those issue numbers and DIOs.
  • Hi Kristi,

    how would you like me to deliver the file? I can't see a messaging system in this forum. My email address is tchristie61 at gmail dot com. If you email me, stating which version of the csl (with double spacing, or with double spacing/no issue/no DOI, or both) and I'll email it/them to you.

  • edited September 2, 2008
    Hello, I have an issue where my bibliography has an extra carriage return after only a particular reference. And I checked to see if the DOI field had a carriage return and it did not...

    Any ideas?

    It looks like this (with some other references for context):

    Kawato, M., Furukawa, K., & Suzuki, R. (1987). A hierarchical neural-network model for control and learning of voluntary movement. Biological Cybernetics, 57(3), 169-185. doi: 10.1007/BF00364149.
    Kawato, M., & Gomi, H. (1992). A computational model of four regions of the cerebellum based on feedback-error learning. Biological Cybernetics, 68(2), 95-103. doi: 10.1007/BF00201431.
    Kawato, M., Kuroda, T., Imamizu, H., Nakano, E., Miyauchi, S., & Yoshioka, T. (2003). Internal forward models in the cerebellum: fMRI study on grip force and load force coupling. Progress in Brain Research, 142, 171-88. doi: 12693261.

    Kelly, A. M. C., & Garavan, H. (2005). Human Functional Neuroimaging of Brain Changes Associated with Practice. Cereb. Cortex, 15(8), 1089-1102. doi: 10.1093/cercor/bhi005.
    Latash, M. L. (2008). Motor Control: The Heart of Kinesiology. Quest, (60), 19-30.
  • I am really sorry for bringing up a prehistoric thread like this one. dont like necrobumbs, either. but. i still have this very problem.

    1. open new, empty word doc (word 2013)
    2. insert some citations (zotero
    3. choose "Angewandte International Edition" as style
    4. insert bibliography
    5. observe empty lines between items

    i did check in chrome://zotero/content/tools/csledit.xul that particular style. it has, as it should, "entry-spacing=0" in the bibliography tag. in the preview, it looks fine. no empty lines, no additional paragraphs. in word though, it has. what should i do? recommendations? should i open a ticket for it?
  • wow, thank you very much. did intensive google and in-forum search. didnt find that. am sorry, but hope it helps others :) have a nice day.
Sign In or Register to comment.