"create bibliography from selected item" question / error

This question concerns the feature that lets you copy a quick citation into your copy cache that you can later enter into a document manually via paste by right clicking on a given Zotero entry. In the past I routinely selected the format "Chicago Manual of Style (note)" and it would spit out something like:

John Smith, Title (Place: Publisher, 1999).

Inexplicably now when I select that option it spits out the full citation version:

Smith, John. Title. Place: Publisher, 1999.

In fact, the citation is copied in the exact same format as "Chicago Manual of Style (full note)." Why did this happen and how do I change it back to the way it used to be?
  • edited March 15, 2012
    To configure your Quick Copy preferences, click the Actions menu (the gear icon) and select Preferences. Within the Preferences pop-up window, select Export. From this tab you can do the following:

    -Set the default export format
    -Set up site-specific export settings
    -Choose whether you want Zotero to include HTML markup when copying

    You can also use Quick Copy keyboard shortcuts to copy citations and bibliographies to your system clipboard and then paste them into documents. See the Shortcut Keys preference pane for the default keys.
    Edit: I had misunderstood your problem...
  • If I understand correctly, what's happening is that there used to be Chicago styles without a bibliography. If you used quick-copy, they pasted a citation. Those don't exist anymore (for a number of reasons).

    You can still get a citation (i.e. the format with parentheses) via quick-copy, though, by shift-dragging the item(s) in question or using ctrl+alt+a

    (I thought we had added that to the documentation somewhere more prominently?)
  • edited March 15, 2012
    We updated the instructions in the Export pane, but it won't be in until 3.0.4:

    "For bibliography styles, you can copy citations or footnotes by pressing Ctrl-Alt-A[/Cmd-Shift-A] or holding down Shift before dragging items."

    We should update the documentation too.
  • Oh, but pickettj is using the right-click option, not Quick Copy. For that, we're planning to add an option to the "Create Bibliography from Selected Item(s)" dialog that allows citation/footnote generation. I'll try to get to that for 3.0.4.
  • Thanks for your help.

    I was not previously aware of Quick Copy, but unless I am doing something wrong, that does not really solve the problem - on my computer it merely copies the author and book title. Is there a way to make Ctrl-Alt-A spit out a full footnote?

    So if I understand correctly, the feature that I used to use all the time - "Create Bibliography from Selected Item(s)" - to generate on the fly footnote-format citations was simply removed?
  • pickettj - if you want a full footnote, you need to use the "Full Note" version of the Chicago style - that has always been the case, though.
    The "Note" style gives you the short version of the note in Chicago style.

    The feature wasn't removed in Zotero, no - it only existed because the style didn't have a bibliography specified and that version of the style was removed from the style repository.
  • Right, but I get the exact same thing no matter whether I choose full note or just note - and both of them are in bibliography format with the author coming first, not in footnote format. In both cases, Zotero spits out:

    Last Name, First Name. Title. Location: Publisher, Date.

    What I want it to spit out (and what it used to spit out without issue) is:

    First Name Last Name, Title, (Location: Publisher, Date)

    Is there any way to still accomplish this, control alt A or otherwise?
  • Yes, that's what we've been talking about all along.
    Select the Chicago Full Note style for quick copy (follow Gracile's link above). Then use shift+drag or ctrl+alt+a [Mac: cmd-shft-a] and paste and you'll get
    First Name Last Name, Title, (Location: Publisher, Date).
    If you don't, you're almost certainly doing something wrong.
  • Wonderful, that works. Thanks very much - this is even more efficient and convenient than before.
Sign In or Register to comment.