Can't read CiteULike

Zotero is saying that it can't read the search pages on CITULIKE.
Individual pages are read.
Searches that have one hit are not read and Zotero
does not say "Can't read" in that case.
The Debug ID is D2016701068
Screenshot with more hits
Other places are working okay.
  • Works for me for exactly that search.
    Do you get the error immediately after clicking the folder icon or after selecting some citations to import?

    Can you confirm that that's still the problem? - might have been a temporary issue on their site.

    Do you have an example for a search result with one hit? That's probably easy to fix.

    Dan - what's the error in the Debug ID?
  • edited March 10, 2012
    Thank you, yes, I can confirm that this is still happening.

    This time I
    1) Disabled all other addins other than zotero
    2) close all other tabs other than Citeulike
    3) performed a search that yields two hits
    4) performed a search that yields one hit

    The error occurs immediately upon clicking the "yellow folder icon," and says "Could not save item. An error occurred while saving this item..." which is strange since, as you point out, I had not specified an item to be saved yet.

    I tried right clicking the yellow folder too

    The Debug ID is D1129711899
    With the error being presumably this bit
    (4)(+0000000): Translate: Parsing code for CiteULike
    (3)(+0000001): Translate: Beginning translation with CiteULike
    (2)(+0000000): Translate: Translation using CiteULike failed:
    fileName => chrome://zotero/content/xpcom/translation/translate.js
    lineNumber => 432
    string => Error: Translator called select items with no items
    url =>
    downloadAssociatedFiles => true
    automaticSnapshots => true

    Wherein above, the error seems to be because it is going straight to attempting to download before I have been given the chance to select something, and so throwing an error be cause nothing has been selected.

    There are lots of other places were I can search so I am happy.
  • yeah, that's the error, thanks. I can't replicate it unfortunately -
    I'll take a closer look soon, but unfortunately this will involve a bit of guesswork on my part so it won't be easy - but obviously I'd like to get this fixed and presumably you're not the only person for whom this fails.
  • I got the same error on another computer
    and at
    But I have the same extensions installed in this computer. Perhaps I need not only to disable them but uninstall them. I will be installing zotero on a third computer which is nearly vanilla and report back then. This is Japanese windows 7 64 bit incidentally.
  • disabling extension should really be enough, don't bother de-installing.
    Could be something they citeUlike changes when you're accessing it from Japan - hard to say.
    I might ask you to help me troubleshoot at a later point (i.e. I'll ask you to install a version of the translator that produces more debug output), but that will take some time until I get to it.
  • There was once an issue with Flickr css that only occured in Japan, so it is not out of the question.
    I'd be happy to install a debugging translator.

  • Can you see if you still get that error? I'd have some time to debug this now.
Sign In or Register to comment.