insert bibliography failing with Zotero 3.03 and LibreOffice 3.5.0 on Mac OS X 10.7

I'm on a Mac running OS X 10.7 AKA Lion

I'm up to date with LibreOffice (3.5.0) and Zotero Stand Alone (3.0.3), along with the most current LibreOffice integration plugin.

Everything has worked fine previously. Tonight, when I went to add a new bibliography to a new paper, Zotero bombed. This involved:

1) The bibliography is inserted without any formatting or line feeds. This is the case with several different styles, including APA6
2) Zotero itself begins to use up to 100% of available CPU resources
3) I can't quit Zotero and have to force quit.

I've tried:
1) reinstalling the LibreOffice plugin
2) reinstalling Zotero
3) rebooting

Nothing works. This is a serious disaster for me if Zotero is suddenly failing.

  • If you're in a hurry, I would be inclined to say to try downgrading LO to one of the 3.4 versions. That's purely speculative, but there have been some reports of issues with LO 3.5 and none with LO 3.4.
    If you have a little time, though, I'm sure Simon would be glad for some help troubleshooting this, he'll likely follow up with some questions.
  • Thanks. The current reply to comment on a previous paper is short and only has 4 citations. So I can do it manually. I have a couple of others and a grant proposal coming up in the next month. So it's not yet urgent, but will rapidly become so. Maybe we can trouble shoot in that time frame??

  • If you can follow the steps to provide real-time debug output during the hang, that would be useful in tracking this down. You can email the output to
  • OK. I'll try this later today and send it in for you. Thanks much for your help.

  • I've emailed the debug output to, referencing this discussion thread

  • edited March 9, 2012
    Unfortunately it looks like this may be the same bug in OOo that was supposed to be fixed a few weeks ago. The best solution is to use OOo 3.4 until they fix it again.
  • To be sure, Simon means LO 3.4, not OOo.
  • Right. Sorry for the confusion.
  • Reverting to LibreOffice 3.4.5 works.

    The LO error you linked to was about RTF pasting--and that makes sense here. But I wonder why this also results in Zotero suddenly using all available memory and then refusing to quit without a force-quit.

  • edited March 13, 2012
    According to the latest posts on the bug above, the bug only seems to appear when "experimental features" are enabled in the LibreOffice preferences.

    The Zotero side currently has undefined behavior when the Java component throws an exception. We'll fix in a future release.
  • Yes! Thanks very much. When the "experimental features" are turned off, Bibliography insertion works fine in LO 3.5.0.

    It was never quite clear what new "features" were available with this option anyway. So turning it off is not a problem for me.

Sign In or Register to comment.