Firefox error - "Please restart Firefox"

Reporting error 673914155 - this was the second time I got this error when opening the Zotero plugin. And yes, I restarted Firefox and got the error again. In addition to the error message, I am unable to close the Zotero view on this webpage (which takes up the lower half of the screen). When I hit the "x" I get a "There was an error starting Zotero". Only closing the window seems to help!

No Office applications are open, only Outlook.

Versions: Zotero 3.0.3, Firefox 10.0.2, Windows 7 SP1
  • Does this occur after restarting your computer?

    If so, see his:
  • Yes, I just (sigh) rebooted to demonstrate that it's still happening. I then went through all the steps to get the Error Console in Firefox, and I combed through the Errors and Warnings. There were very many errors related to some Google Drawings I was editing; I closed those documents. There were also a bunch of errors related to the web page I was trying to capture in Zotero ( Then there were a couple of chrome:zotero errors that zipped by and disappeared before I could read them. The only one I can find now is:

    Warning: Key event not available on some keyboard layouts: key="z" modifiers="accel alt"
    Source File: chrome://browser/content/browser.xul
    Line: 0

    But when I clicked on the Zotero Firefox plugin, immediately this error popped up: State check failed due to transaction in progress.

    What could this mean? I know I don't have Zotero open in any of the windows I have open.
  • Then there were a couple of chrome:zotero errors that zipped by and disappeared before I could read them.
    Those are the ones we need, I'm afraid. If possible, close all open webpages and then try again. Web page warnings can cause the errors to fall out of the buffer.
  • edited February 28, 2012
    Hi Dan,

    I think I've got some juicy errors for you. I closed all my windows and tabs except for 1 window, 3 tabs... this did not cure Zotero which still gave the error when I opened the plugin.

    Warning: Error in parsing value for 'background-image'. Declaration dropped.
    Source File:
    Line: 348

    [unrelated errors removed — D.S.]
  • edited February 28, 2012
    No, errors are irrelevant, as that page mentions.

    Follow the steps on that page again.
  • Ok,these are all the chromse://zotero ones:

    Error: Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFileInputStream.init]
    Source File: chrome://zotero/content/xpcom/translation/translator.js
    Line: 439

    Error: [Exception... "Component returned failure code: 0x8052000e (NS_ERROR_FILE_IS_LOCKED) [mozIStorageConnection.executeSimpleSQL]" nsresult: "0x8052000e (NS_ERROR_FILE_IS_LOCKED)" location: "JS frame :: chrome://zotero/content/xpcom/db.js :: <TOP_LEVEL> :: line 1003" data: no]
    Source File: chrome://zotero/content/xpcom/db.js
    Line: 1011
  • OK, that's more like it.

    Check the permissions on your Zotero data directory. This could also be due to security software on your system.
  • (You should be seeing the Zotero logo in the status bar with an exclamation mark over it, which when clicked should display the message "The Zotero database cannot be opened. Make sure you have read and write permissions for all files in the Zotero data directory." If that's not the case for you, we'll have to look into why that is.)
  • I get the Zotero logo with the exclamation mark, but the message is just "There was an error starting Zotero".

    I had read/write permission on the folder, but there was a "Read only" box checked... I unchecked it and am restarting Firefox, let's see if that does anything...
  • Still getting the error, and just lots of Zotero is not defined errors in the console, and State check failed due to transaction in progress.
  • Should I try uninstalling/reinstalling?
  • No. This doesn't have anything to do with Zotero code. You need to fix the permissions problem on your system. If you're running security software, try disabling it.
  • I did something just to see if it would help, and it seems to have "healed" my Zotero plugin (crosses fingers). I downloaded and installed the standalone client, and used it a couple of times on its own. Then I tried opening the Zotero plugin (clicking on the "Z") in a browser window. No error message. When I tried to capture a web page using the plugin, it either shifted me over to the standalone, or, if there was a "capture" page icon in the address area, it captured the metadata and shifted me to the client.

    After I closed the client, then re-opened and tried the Zotero plugin by itself, it worked!

    Unfortunately, I have no idea WHY it worked...
  • Unfortunately the fix might be temporary (though reproducible). The error you were getting was from Zotero for Firefox trying to update the site translators in the Zotero data directory. There may be some security software on your system that's preventing Firefox from accessing the filesystem, but Zotero Standalone, which by default shares the same data directory, wouldn't be subject to the same restrictions and so was able to update the translators. This means that the next time Zotero for Firefox tries to update its translators you might have the same problem.
  • I wasn't able to see the problem with security, but I will mention it to our desktop support folks and see if they can figure it out. At least if it happens again, I have something I can try!

    Thanks for working with me on this.
Sign In or Register to comment.