Entries lost after reinstall

A computer service person here at work installed a new program on my PC. They say they didn't do anything else but when I got back to my computer all my firefox bookmark preferences were wrong and zotero was missing. Luckily I had backed up previously. I reinstalled Zotero, which may have also been an upgrade for me. Strangely, all of my recent entries into Zotero were missing.
I tried removing the current .bak files to a temp folder and inserting the old ones, but then the new zotero wanted to convert them and they all came through missing again. I tried reinstalling old zotero but new firefox says its not compatible.
Maybe I'm confused and my backup doesn't even contain the missing data. But it must be somewhere?
It's giving me a sore head trying to figure out what to do. Can anyone help?
  • Thank you I had found that link previously and followed all of the suggestions where possible.
    I thought the most relevant section for me was the "where did my items go?" at the end.
    I followed the profile link (which was confusing as it doesn't actually take you to a totally relevant page) but eventually I found that I only have 1 profile (default) so I am using that.
    Any further suggestions?
  • Well, as the page says, "If you're not sure where your data is located, it's a good idea to look for larger versions of zotero.sqlite or zotero.sqlite.bak stored elsewhere on your hard drive and to look in the 'storage' directory for recently saved PDFs and other files."

    If you lost your Firefox bookmarks as well, it seems pretty clear that you're not in your original Firefox profile. Whether that exists somewhere else on your system or was wiped out I obviously can't tell you.
  • edited February 22, 2012
    Also, if Zotero wanted to upgrade your database, it was either a very old backup or you put in the wrong file (e.g., renaming an old numbered .bak file from the backup instead of just using the zotero.sqlite file). Zotero hasn't upgraded the database in over a year. Be sure to carefully follow the instructions on the page I linked to about restoring from a backup.

    But there shouldn't really be any mystery as to when the backup is from—just look at the timestamps on the files.
  • Thank you for your help.
    The problem is kind of solved... the data all appears in "my library" tab on the zotero website. I don't usually use this, I use the firefox add-on. So it is on the web, not on my computer. What does this mean? How can I get it to go back into my firefox add-on?
    As I mentioned before, someone else was operating on my computer. Who knows what they did.

    p.s Thank you for reminding me of the "date-stamp" which showed that the data I had found was too much of an early back-up. I did a search of all my HD and no cigar.
  • So it is on the web, not on my computer. What does this mean?
    It means the person wiped your local Firefox profile, including your Zotero data directory. That wouldn't affect your synced data.
    How can I get it to go back into my firefox add-on?
    Close Firefox, delete your Zotero data directory, open up Firefox (to what should be a new, empty library), and sync. It will pull down your data from the server.
  • Thank You Dan Stillman,
    I'm a happy little vegemite again.
  • my problem appears to be similar. or worse. i logget out of zotero, and when i locked in again, all my data was gone. i had a problem with synchronisation. is everything gone, or is my data saved somewhere in the huge world of world wide web???
  • what do you mean by "logged out"? And do you still have your data locally? which Zotero version are you using.
Sign In or Register to comment.