Standalone not importing from Safari or Firefox with Windows 7

I am using the most recent version of standalone and it does not seem to be working with the Safari or Firefox extensions. When saving a snapshot the dialog box in the bottom right corner of the browser says it is saving the item, but I cannot find it in the database.

I have restarted the browsers and the computer to no avail.

Zotero for Firefox worked fine before I installed the standalone.
  • I am visiting my university library databases to look for journal articles. Prior to standalone I would click the document icon in the Firefox menubar to save information to the database, but with standalone that is not present. Using either Firefox or Safari with standalone the same thing happens. The only way to save information to standalone is to right click on the page and select the "Save zotero snapshot of current page". When I do that the pop-up window in the lower right hand corner appears saying it is saving. However, the zotero database has not been updated and I see not record of anything being added to the database.

    I have installed the zotero extensions to both Safari and Firefox, but that did not seem to make a difference. Maybe I am using zotero incorrectly and there is a different way to get information into the database. It was pretty seamless when I used Firefox pre-standalone.

    Also, at home tonight I am using Lion on my Mac with Safari to access the databases. I updated the standalone and installed the Safari extension. Now it looks like there are two ways to get information into zotero. I can right click on the page and save a snapshot or I can click the icon next to the address bar to save to zotero. The greyed out z changes to a page icon when I hover over it.

    The problem with the Mac installation is that the snapshot only puts a link to the current page in the database with no other information (maybe that is how it is supposed to be). Clicking the page icon does not update the database but the pop-up in the lower right of the browser window shows "saving Item..." Again, no updates to the database.

    Sorry for the long post, but I enjoyed zotero with Firefox, and not it is not working.

    Any suggestions would help.

  • We can try to help you with these issue, but you do realize that if you close Standalone, the Firefox extension simply reverts to functioning the same as it always has? So if you're in the middle of work, you can just use Zotero the way you always have.
  • That is good to know. Thanks
  • Can you generate a report ID in both Zotero Standalone and Safari after clicking the button next to the address bar on a site where you get an icon?
  • That's just it. I cannot get an icon at any site I visit. I am currently working with the Windows version of Firefox and cannot get an icon with my database searches, or on Amazon. However, I did see these errors in the report log. The last one was repeated 10 times.

    Failed to load native module at path 'C:\Program Files (x86)\Zotero Standalone\extensions\\components-9.0\zoteroWinWordIntegration.dll': (80520012) <unknown; can't get error from NSPR>

    Failed to load native module at path 'C:\Program Files (x86)\Zotero Standalone\extensions\\components-8.0\zoteroWinWordIntegration.dll': (80520012) <unknown; can't get error from NSPR>

    [JavaScript Error: "[Exception... "'Cannot access database layer from a higher wait level if a transaction is open' when calling method: [nsITreeView::isContainerEmpty]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]"]
  • By the way, the report ID for the errors is 1136036044
  • I am currently working with the Windows version of Firefox and cannot get an icon with my database searches, or on Amazon.
    Meaning you're using Zotero for Firefox in connector mode, connecting to Standalone? Have you tried in Firefox with Standalone closed?
  • It works with Standalone closed. Although the report ID 320312531 was generated when I opened the Firefox version of Zotero. All I did was launch Firefox and look at the error report right away.
  • Just to make sure - you don't see a URL bar icon here:
  • Translator with ID d75381ee-7d8d-4a3b-a595-b9190a06f43f already loaded from "Scitation ([name] iMac's conflicted copy 2011-07-27).js
    You have your Zotero data directory in Dropbox. You absolutely shouldn't do that, and we can't help you further as long as that's the case. Move it out, reset your translators from the Advanced pane of the Zotero preferences, and try again.

    Provide another Report ID if you still have trouble.
  • Sorry, relic from a bygone era. I removed the Dropbox connection and it has started working with Firefox. I am still having trouble with Safari so there may be other issues. I don't want to spend a lot of time on it, unless there is something obvious I should try.
  • does it work with the amazon link above? If so, what's an example where it isn't working.
  • The link does not work with Safari browser version 5.1.2
  • Something else just came up. I am working at home on my iMac running Lion with Safari. Standalone was working beautifully until it didn't. There looks to be an extensive error report on 1335276931 that describes what happened. I was using a database to research articles and was able to save 3-4 before the toolbar icon stopped showing the save link. It remains as a greyed out Z. I even tried articles that worked previously to no avail. I am going to try to restart the browser to see if that helps, but wanted to generate and send an error report prior to doing that.
  • Upon restarting the browser the proper icons re-appeared, however when I clicked to save an article the saving process stalled. Now the icon is back where it was, greyed out Z.

    error report 1569507699
  • Hello Dan,

    I have the Zotero database in the Dropbox folder, too.

    Where is the problem?

    Plus, I also cannot import a website from Safari to the standalone version of Zotero.

  • Maybe I put it unclear.

    I synchronize my Zotero database with via the sync settings in the program.
    Additionally, I have the whole Zotero database in the Dropbox folder, for backup.

    Works fine, I haven't had any conflicts, yet. Continuing to work with the iPad after I have used the Mac before instantly brings the latest updates in.

    Yes, it is permanently synchronizing in the back while I am actively working in Zotero, but that doesn't bother me.

    Steps to reproduce that I cannot import a website:
    1. I surf in Safari (Mac Mountain lion) and find a website I would like to import.
    2. The Zotero button is on "Z" (no metadata found), hovering over it or clicking on it doesn't have any effect.
    3. I have to add a new item right in Zotero, copy and paste the URL into it and type the name of the website.
  • If you're syncing to Dropbox from only one computer (i.e. for backup) you're fine. Problems occur when multiple computers sync through dropbox.

    The Zotero button in Safari is only active for supported sites such as
    For all other pages, use right-click (anywhere in the webpage) --> Save as Zotero Snapshot
  • I did not know that.

    Thank you very much, adamsmith.
Sign In or Register to comment.