LibreOffice and Ubuntu pre-release fail (see error inside)

An error occured communicating with Zotero:
at java.lang.HashTable.put...

The full error message is at: (sorry could not copy the message box content)

- Ubuntu 12.04 alpha2
- LibreOffice 3.5.0beta2
Same error occurred when using current master branch (identifies itself as LibreOffice 3.6).
- Office integration plugin 3.5.1
- Zotero version 3.0.1 (in Firefox 11)
Same error occurred when I downloaded current Zotero standalone.
Same error occured when I downloaded and used Firefox 10 with Zotero.
- Java identified by LibreOffice: Sun Microsystems 1.6.0_24 (openjdk)

I am a bit stumped whether I should be blaming Java, LibreOffice, Zotero or the integration plugin, since people are clearly running it in Firefox 10, and using Libreoffice 3.5...
  • P.S. I should have mentioned that the error occurs when trying to insert a bibliography. Inserting a citation works fine and is shown in LibreOffice. When inserting the bibliography the error message is shown. Leading to a blank bibliography in LibO and a forever running Firefox (quitting firefox will not exit the binary)
  • P.P.S. Just saw the comments about vanilla versus Ubuntu versions of Firefox. When I tried with a downgraded Firefox 10, I used the vanilla version from, so that was not it...
  • I think there is a LO issue that they said would be fixed before the final release of 3.5 - Simon would have to confirm that's the same error.
  • I do hope so, but given that I tested a self-compiled "master" branch (ie post 3.5) in adition to 3.5rc2, it seems that no fix has gone into it yet. Which would be bad. Is there a bug number that I can look up?
  • I was testing workarounds for the LibreOffice bug and it looks like that test code accidentally made it into the release version. We'll release a fix shortly that should make this work with 3.5.0rc3+.
  • Fix released.
  • The good news that this has improved something :-). A bibliography is shown sometimes and this error messages has gone. Sometimes, e.g. if I only have one reference, I get: (a off-by-one count somewhere?)

    (also the formatting of the bibliography seems to be broken in that all references are lumped together without a newline in the reference list independent of which style I chose)

    But that could be an entirely different issue now.
  • And thanks for the extremly quick response. I am very impressed.
  • Are you using LibreOffice 3.5.0rc3? That looks like the bug in LibreOffice 3.5.0rc2 that we've seen before. Everything is working fine for me in 3.5.0rc3.
  • Yes, that was with rc2. I will try the current master branch soon to see if things work,
  • I am using LibreOffice and Ubuntu 12.04 beta 2, and have this problem
  • edited April 12, 2012
    If you are getting the first error mentioned in this thread, it's because you have an out of date version of Zotero LibreOffice Integration.

    If you are getting the second error, it's probably because of this.
  • edited April 17, 2012
    Zotero does not launch properly on ubuntu 12.04 beta if locked the launcher on its first run.
Sign In or Register to comment.