Syncing word documents

I've successfully synced all my word documents from my computer onto my Zotero online library, but when I try to download them, they won't open. When I uploaded them to my Zotero library I did 'save a copy of the file' assuming that meant the whole document would be stored online. Can you help?
  • They're not downloading to another computer your syncing or you can't access them from your online library?
  • It looks like I've uploaded them to my online library, but when I try to download them again (onto the same computer - I was just checking it worked)it can't open them. It looks like they're saved as some sort of file extension that can't open on my machine...thanks.
  • Dan or Simon would have to provide specifics, but I think you're only supposed to be able to open pdfs from the online library - other files will just sync other computers.
  • Thanks for your help.
  • All single-file attachments should be able to be opened from the online library (and opening of multi-file attachments is coming).
    It looks like they're saved as some sort of file extension that can't open on my machine
    You'll need to be more specific.
  • Sorry.
    I go to my online library and click on the document I want to open. The title comes up with an option at the bottom to download. I click on this and it asks if I want to open or save. It is a .odt file. If I try to open it nothing happens; if I save it then try to open it, an error message appears saying it cannot open the file because there is something wrong with the contents.
    I have saved a lot of word docs - I thought because I had clicked on save a copy of the file it would be the entire document saved, but it is calling it an attachment, so maybe this is where I have gone wrong.
  • .odt it the Open Office/Libre Office file format - are you sure the document you uploaded was created with Word and not with one of those programs?
  • Yes, they are all Microsoft Office Word Documents
  • edited February 8, 2012
    Save the files with a .docx extension.

    1) What OS are you using?

    2) What browser are you saving the files with?

    Zotero is interpreting these as OpenDocument files on import, which is apparently causing either Amazon to serve the files as .odt or your browser to override the .docx extension. I'll investigate, but the files themselves are still .docx files, so just save them as such.
  • Thanks for your help - I'll try again.
  • edited February 8, 2012
    OK, this isn't a new issue—the underlying problem actually dates to 2008. All ZIP files (which is what .docx files really are) are being detected as OpenDocument files by the client right now, and that's being synced to the server. Some browsers care what file type the server says it is and some don't, but saving with the right extension will always work, since the file itself is unaffected. We'll fix this in a client update and correct entries currently on the server.
  • Thanks again. I just tried again to save the files, but there is no option to save as .docx or .odf. They say they are saved as .docx, but still try to open as .odf. Hopefully your solution will work.
  • You didn't say what OS or browser you're using, but you can certainly rename the file to whatever you want. You may need to fiddle with your OS settings to get it to display all extensions, though.
  • I'm going to assume you're on Windows:
  • Sorry Adam, it is Windows but I've no idea which version. I don't know where I can rename the file. It is saved as a .docx file but to open it there is an .odf attachment. There is no option to open it in any other way.
  • have windows show you the file extensions - that's what my link is for - you almost certainly saved the file as .docx.odt
Sign In or Register to comment.