odd disambiguation/failed citation update

before I "complain" about a problem, let me first congratulate the developers for the new version. I quite like the new quick-format citation, it's much faster and more straightforward.

I have just come across something strange: I was citing two works by the same author, but one of the records had slightly misspelled a name. Oddly, Zotero treated both as the same and disambiguated them (2004a/b). The real problem, however, is that I have now corrected the record but it doesn't update in my document. I have closed/restarted both Firefox (9.0.1) and Libreoffice (3.4.3) and have deleted/re-inserted one of the citations in the document to no avail it keeps using the misspelled name. Any help would be much appreciated. Perhaps I should also add the titles in question are a book chapter whose author is also the editor of the same book which is the second citation.
(running Ubuntu Maverick)
  • Have you tried switching away to another style, and then back? That should constitute all of the data used for disambiguation. If that doesn't help, you might try copy-pasting the content of the document into a fresh one. If you still get the anomaly after that, my first guess would be that it's still finding the bad name somewhere in Zotero.
  • thanks, it first didn't seem to work, but after I deleted the citation's prefix it did.
Sign In or Register to comment.