Zotero 3.0 fails to insert footnote citations with LibreOffice 3.5


I just upgraded to Ubuntu 12.04, and thus I am running Firefox 10.0 and LibreOffice 3.5 (bleeding edge, so to speak). Since older Zotero versions don’t install with Firefox 3.0, I also upgraded to Zotero 3.0.

Now, Zotero has troubles with generating citations with footnotes: It creates a footnote, but inserts only a few newlines, while the actual citation is inserted in the text body behind the footnote mark.

With an existing document, I do get a Java error, the empty footnote is created (also containing a few newlines), but no citation is inserted at all. I am not absolutely sure if these errors stem from the same source, but maybe the error message gives a hint.

You can find a screenshot of the error message here: http://ubuntuone.com/4XPHj2foDOsoKSkO9i8aT9

A screenshot illustrating the footnote issue is here: http://ubuntuone.com/1L6l9dcO3cmdViUlqMP2H0
  • but other citation styles work OK?
  • I thought they did. Inserting a citation with Chicago Author-Year worked fine.

    But now I noticed that I get the same java error when inserting the bibliography. So maybe there is some code that is called for footnote citations (since they contain more text), and only within the bibliography for author-year citations?
  • edited January 25, 2012
    Thanks for reporting this. There appears to be a regression in LibreOffice 3.5rc1 that breaks the function we use to insert formatted text. I've filed a bug with LibreOffice. I hope someone will care enough to fix this for 3.5 final...
  • Looks like the fix for this will make it into LibreOffice 3.5.0 final.
  • Unfortunately they say the bug you filed is resolved but I'm getting the error precisely as described above when using Libreoffice 3.5 (I also deleted all Application settings) and Zotero 3.0.2 on Windows XP.

    Felwert is it fixed for you? Just in case it's my installation that is at fault.
  • felwert and cokelly72,

    Regarding the java.lang (etc.) error that your seeing, have you tried: (1) checking Tools > Options > LibreOffice > Java to see whether "Use a Java runtime environment" is checked and (2) reinstalling the Zotero Libre/Neo/OpenOffice extension?

    It seems like I've seen this error message before too, and I think one of these things did the trick, but I'm having trouble remembering exactly what the fix was.

    Simon and cokelly72,

    LibreOffice 3.5.0 (final) just came into the LibreOffice PPA for Ubuntu Natty users. So, my system updated to 3.5 earlier this morning, and now I'm having exactly the issue felwert depicts in the screenshot above when I try to edit a Zotero citation in an existing document: the updated citation text doesn't get reinserted after I finish in the citation editor.

    Also, just to see how things would work, I started a new blank document in LibreOffice, inserted one Zotero citation once and got this very bazaar output into the document: the citation is duplicated and inserted not in the footnote but in the main text by the footnote anchor.

    For thoroughness' sake, I have tried reinstalling the Zotero extension, but get the same behavior. For now, I suspect it may be necessary to downgrade back to LibreOffice 3.4.x in order to get things to work properly again, but perhaps this additional information might be helpful for resolving the issue (?).
  • Update on my reply to Simon and cokelly72 from 3/1: I just installed LibreOffice 3.5.0, the current Zotero firefox addon, and the current LibreOffice plugin on an Ubuntu Natty virtual machine. There, the output for the footnotes comes through normally in the footnotes rather than in the document's main text. One difference on the virtual machine is that I didn't make any changes to the default LibreOffice document template. I'm not sure if this helps further diagnose the issue at all, but I thought I'd mention it.

    Thanks so much.
  • Simon says in a different thread that the problem in LO 3.5 has reappeared - so right now installing 3.5 is not recommended.
  • It currently looks like the bug only appears when "experimental features" are enabled in the LibreOffice preferences.
  • edited March 15, 2012
    Thanks, adamsmith and Simon. It looks like this bug should have been resolved again in LibreOffice 3.5.1 (RC1 change log), but it still reappears when experimental features are enabled, even in in LibreOffice 3.5.1.
Sign In or Register to comment.