Can't see tag selector even after toggling

I have just installed Zotero on my USB stick yesterday. I have started to use it, but cannot find any way to display the tag selector. Toggling just moves the bottom of the "Collections" column up and down a millimeter or so. I have added some entries with tags, so there are some present. Is this me or is it a bug? (PC, Win XP, Firefox 2.0.11) (Can't find a way to find the version number of Zotero easily either. )
  • Additional comments (or additional weirdness!)
    The Tag selector is visible if the Zotero window is running above the Firefox window, but not below. This occurs on both computers, home and work. I'm guessing this is a bug? To change it from one to the other I open Zotero "preferences" and change the selection above / below, and restart Firefox & Zotero. Above, tag selector displays. Below, it doesn't.
    Zotero version 1.0.3
    I would prefer to run Zotero below Firefox. Can anyone help?
  • Julia: You should be able to bring the tag selector into view simply by dragging up the area that appears below the collections pane—I suspect that's the divider between the two panes. (You might need to enlarge the Zotero pane itself before you can do so.)
  • Thanks for the extremely prompt reply,
    However, that does not work either. I tried both ways with a reduced and an expanded Zotero window with the Zotero interface preference set at "below", but although I got the double headed arrow cursor mark, both times, it did not drag anything into view. I could send a screenshot but I think attachments are probably a no-no
    (OS Win XP 2002 SP 2)
  • You can send a screenshot to

    You should also go to about:config in the Firefox address bar and make sure nglayout.debug.disable_xul_cache either doesn't exist or is set to false, since that tends to break the tag selector.

    If it's active, you can also go to Report Errors in the Actions (gear icon) menu, send in an error report, and post the Report ID it gives you here.

    You might also try closing Firefox, deleting (or moving) the file localstore.rdf in your Firefox profile folder, and restarting Firefox. The file contains window settings and will be recreated automatically.

    And if none of that works, you should try disabling all other extensions except Zotero.
  • Sorry I am a bit inexperienced and don't know how to "go to about:config in the Firefox address bar and make sure nglayout.debug.disable_xul_cache either doesn't exist or is set to false", although I did have a go. Can you provide more details?
    I am using a portable edition of Firefox on my USB stick. Could that be an issue?
    The only extensions I have are Zotero and a tool called "Switch Proxy", although I have also added the Word plugin
    I appreciate that you must be as they say, "busier than a one armed paper hanger" and am very pleased that you can pay attention to a relatively low priority issue, compared to those people who have troubleshooting problems preventing them completing papers and theses due in.
  • In the Firefox address bar (where you type web site addresses), type about:config, hit Enter, and look for nglayout.debug.disable_xul_cache in the list. You probably won't find it. If you do, and it's says that it's set to true, double-click it to set it to false.

    You can try the other things I mentioned as well, but the most likely fix will be to close Firefox, go to your Firefox profile folder, and delete the file localstore.rdf, and then restart Firefox.
    troubleshooting problems preventing them completing papers and theses due in
    (Yes, well, we try to help with those too.)
  • Oh Frabjous Day calloo callay!!! It works!
    I got what you meant about the address bar and felt dumb. However as you predicted, the disable cache line was not there.
    The profile was a bit tricker, as the portable edition of Firefox has a quite different path from those suggested on the Mozilla site,
    G:\System\Apps\Firefox portable 2.0.11\FirefoxPortable\App\firefox\defaults\profile
    However I found the file "localstore.rdf" and deleted it and restarted, but it made no difference even after I went around the “below / above” loop again. Then I had a sudden bright idea. I had an earlier copy of Firefox that I was not using (the U3 version, also on my USB stick. I uninstalled it and lo! Tag selector is now visible in “below” mode!!!
    Can you also write a social science thesis?
  • Can you also write a social science thesis?
    That costs extra.
  • Just installed the Firefox portable update and lo! I lost the tag selector again! I have tried deleting "local store.rdf" and making sure nglayout.debug.disable_xul_cache did not exist (it didn't ) but no luck.
    I can't think of a way to repeat my previous success, as to my knowledge, there is no earlier copy of Firefox on my USB, unless the update kept something from the previous copy.
    Any suggestions?
  • Any suggestions?
    Disable SwitchProxy. It breaks the tag selector. (This is why I said above to disable all other extensions.)

    SwitchProxy is using an old Mozilla interface that isn't meant to be used, and it seems to be breaking Zotero (and probably other things). It also appears to be causing a memory leak, which is probably the reason for all the reviews on saying that it slows down Firefox.

    There's a one-line fix, but the extension hasn't been updated since November 2006, so I'm not sure an update will be forthcoming. But you might try contacting the author, who might want to update it for Fx3 anyway.

    (For what it's worth, the fix appears to be to comment out the nsIPrefBranchInternal line in proxy.js and replace "oPrefBranch" on the next few lines with "gSwitchP_Prefs".)
  • Disabling SwichProxy worked. However I tried replacing it with Foxy Proxy because the Mozilla addons site recommended it, but lacked the driving skills to make it work - its very complicated! Thus everything (including the whole of Zotero) ground to a halt until I disabled that too. Is there any proxy switch you would recommend (eg QuickProxy?) that works ok with Zotero? I use a USB key as a main drive, with Firefox portable and Zotero, so every time I switch computers I would otherwise have to manually re-enter proxies and exceptions.
    Thanks for the continued assistance.
    PS, another unrelated comment.
    I think Zotero is fabulous, and it has become an integral part of my daily work. It would be nice therefore to discuss with others, how they use it and what innovations they have come up with in ordering bibliographic access, and if they are using Zotero as a concept building and ultimately an argument building tool for written papers. (Something I would like to be able to do)
    I know there are the special interest groups and have visited them, but the title "special interest' does not give users a clue as to what to do there.
    Instead my suggestion is to set up fora for different disciplines that are named to encourage discussion of use. "How I use Zotero in Social Science", How I use Zotero in Law, Engineering etc. This might encourage more of this type of discussion and give you people more feedback on the less technical side of Zotero usage.
Sign In or Register to comment.