Not signed in (Sign In)
 

Quick Links

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    • CommentAuthoreawtrey
    • CommentTimeJan 16th 2012 edited
     
    I've searched these forums for a while, but can't quite seem to nail down the answer to my issue...

    I've been using FF/Zotero 2.x for quite a while. The combination of citation management and automated PDF download is the killer feature for me. I recently switched my main browser to Chrome for a variety of features, but I find that this nixes my ability to automate PDF downloads to my local computer. Can anyone speak to this scenario?

    EDIT: I'm attempting to use Zotero 3.0 standalone and the Chrome connector.
    • CommentAuthoradamsmith
    • CommentTimeJan 16th 2012
     
    The problem most likely is that you're trying to get to gated pdfs.
    In Firefox, Zotero uses the built-in proxy redirection to make sure that the URL to the fulltext PDF is redirected through your institutional proxy, making sure you have access.
    The Zoter's Chrome/Safari Connectors can't do that. There are extensions for Chrome that will do automatic proxy detection/redirection for you - you'll have to search for them. With those enabled you should be able to get gated pdfs.

    To check whether this is the case, try importing the citation here:
    To
    http://www.advancesindifferenceequations.com/content/2012/1/2/abstract
    You should get a pdf (the journal is open access).
    • CommentAuthoreawtrey
    • CommentTimeJan 16th 2012
     
    Aha! This is true - this link worked through Chrome. I've seen the references to Chrome proxy detectors in other places. I'll track those down, test, and post my final solution here.
  1.  
    Did you ever get this figured out? I'd love to be able to automatically save PDFs!
    • CommentAuthord.bobak
    • CommentTimeJan 31st 2012
     
    I have the same problem also.
    Latest Zotero Standalone (i.e 3.0)
    Chrome 17 (beta)

    In Chrome I have installed Proxy SwitchySharp extension, which automatically redirects me through a proxy (with login and password) for some sites , like Science Direct. When I try to download pdf directly from Chrome, it works perfectly. When I get article to Zotero by an icon on the address bar, it works for open access sites. But it does not work for sites where I have full access only by a proxy. The reference goes to Zotero, but it cannot grab a pdf.

    I have noticed, that there is a settings in about:config like "network.proxy.http", "network.proxy.http_port", but it seems not working for proxies, where I have to authorize me by a login and password. The syntax similar to: user:password@proxy_address does not work. Why there is no proxy tab in Zotero Standalone settings?!

    For Science Direct there is also possibility to login to their site, as a authenticated user I can download pdf's... but of course that also does not work for Zotero Standalone.

    So, anyone have any idea, how to work with Zotero Standalone? I don't like Firefox so much and prefer Chrome...
    • CommentAuthoreawtrey
    • CommentTimeFeb 1st 2012
     
    @lucagiupponi,

    I did not get it figured out. I haven't found a proxy detector that functions like the one in FF did - specifically, I haven't found something that will attach my proxy information to the PDF download portion of Zotero.

    This seems to be the same issue that @d.bobak is having. (They just don't have the automatic proxy switcher in Chrome.)

    @adamsmith seems to think there is some Chrome extension out there that can do this, but all I can locate is a EZProxy extension that adds the appropriate domain name to an address in Chrome - doesn't work for the Zotero download portion.

    Sadness - I, like @d.bobak, much prefer Chrome, but this is the one thing I must fix!
    • CommentAuthoreawtrey
    • CommentTimeFeb 3rd 2012
     
    Update: My workaround, at this point, is to manually download the journal articles (PDFs) that I'm interested in, and then drag-and-drop them into SA Zotero. I can then have Zotero look up the metadata for the PDFs and create proper Zotero links.

    Not ideal, but better than nothing. Hopefully someone will figure out how to make the Chrome-SA proxy situation work better in the future.

    Thanks to the Zotero team! Despite my issues, this is a great product.
    • CommentAuthoradamsmith
    • CommentTimeFeb 3rd 2012
     
    As a better workaround - have a look at the Zotfile plugin. You can install plugins in standalone through Tools--> Add-ons --> Tool Icon (top right) --> install add-on from file.

    https://addons.mozilla.org/en-US/firefox/addon/zotfile/versions/
    (install 2.0)
    • CommentAuthoreawtrey
    • CommentTimeFeb 3rd 2012
     
    Interesting - I already use ZotFile, but how would this help with the downloading of PDFs through SA? Or are you suggesting that for the metadata lookup?

    My current workflow:
    1) Locate article online
    2) Download to local directory
    3) Drag-drop to Zotero SA
    4) Look up metadata via Zotero
    5) Rename & move via ZotFile
    • CommentAuthoradamsmith
    • CommentTimeFeb 3rd 2012
     
    the suggested workflow would be:
    1) locate article online
    2) Download article data using connector and Zotero icon.
    3) Download pdf to download folder
    4) Attach, move, and rename using ZotFile

    That way you a) never leave your browser and b) get publisher data rather than PDF lookup. The former is usually much better.
    • CommentAuthoreawtrey
    • CommentTimeFeb 3rd 2012
     
    Ah, yes! It never occurred to me to use the attach function of ZotFile. I was only using it to sync with a DropBox folder for remote usage.

    Your workaround saves me a step - thanks!
    • CommentAuthord.bobak
    • CommentTimeFeb 7th 2012
     
    Finally, I have found a solution, that works!

    The keyword is local proxy server, in my case it is privoxy (www.privoxy.org).

    1. Download and install privoxy. It may be a good idea to install it as a service in Windows.

    2. Next step, is to tell privoxy to forward traffic aiming to some sites through "parent proxy". In main config file (config.txt in Windows) put some lines like that:

    forward .sciencedirect.com parent_proxy_addres:port
    forward .jstor.org parent_proxy_address:port
    and so on with other sites we need...

    3. Second step is to "force" privoxy to send our parent proxy login and password. We do it in user.action file, put it in the end of the file:

    {+add-header{Proxy-Authorization: Basic BASE64ENCODEDUSERANDPASSWORD==}}
    .sciencedirect.com
    .jstor.org
    .nature.com
    .sciencemag.org
    .scopus.com
    .wiley.com
    .and so on with other sites we need.

    The string BASE64ENCODEDUSERANDPASSWORD== has to be replaced by string:

    username:password

    encoded by Base 64 algorithm. There are many sites with online encoders, for example: http://www.opinionatedgeek.com/DotNet/Tools/Base64Encode/default.aspx
    Properly encoded string ends with two equal signs (==).

    4. Next step, is to tell Zotero Standalone (and possibly our browsers and system) to use privoxy as a proxy server. In Zotero, in about:config we have to change following preferences:
    - network.proxy.type should be "1"
    - network.proxy.http should be "127.0.0.1"
    - network.proxy.http_port should be "8118"
    - network.proxy.ssl should be "127.0.0.1"
    - network.proxy.ssl_port should be "8118"

    The address 127.0.0.1 and port number 8118 is privoxy default, if we changed it in config.txt we should also change it here.

    5. We can also change system-wide proxy setting as well as in some browsers.

    6. It is good to make a restart of Windows, just in case ;)

    After all those steps, I have a fully functional and working Zotero Standalone and Chrome cooperation!
    • CommentAuthorSimon
    • CommentTimeFeb 10th 2012 edited
     
    I have a fix for this (provided you are logged into your library proxy in Chrome) that will probably make it into 3.0.2.
    • CommentAuthoradamsmith
    • CommentTimeFeb 10th 2012
     
    We attach cookies sent from the connector to attachment downloads, which should get most proxies working, provided that the user is logged in.

    That's a nice way to solve (or at least mostly solve) this - cool!
    • CommentAuthoreawtrey
    • CommentTimeFeb 10th 2012
     
    Excellent! I'll be eagerly watching for this :)
    • CommentAuthoreawtrey
    • CommentTimeFeb 17th 2012
     
    @Simon I've downloaded version 3.0.2 - what should I be looking for? Behavior hasn't changed much.
    • CommentAuthoradamsmith
    • CommentTimeFeb 17th 2012
     
    You should get pdfs attached e.g. in JSTOR.
    • CommentAuthoreawtrey
    • CommentTimeFeb 17th 2012
     
    Looks like it works now - I just wasn't being patient enough with JSTOR :)

    EBSCO is sometimes wonky, but I think that may be on my end.
    • CommentAuthorshel
    • CommentTimeFeb 27th 2012
     
    I just installed 3.03 on my windows machine, using Chrome standalone and connector, and am not getting any of the Zotero icons when using jstor from my university library. No problems in EBSCO, though.
    • CommentAuthoradamsmith
    • CommentTimeFeb 27th 2012
     
    You may have to manually accept the terms of conditions once - did you try that?
    • CommentAuthorSimon
    • CommentTimeFeb 27th 2012
     
    What's the URL?
    • CommentAuthorshel
    • CommentTimeFeb 27th 2012
     
    Hi Adam,

    I did accept the terms and conditions. The problem, which I'm having on my linux machine now as well, is that in the address bar, there are no icons for me to click to add a citation to my zotero library. Many of my students who have tried the standalone with Chrome or Safari have had the same problem at our institution. I don't know if all of the problems are related to off-campus access or not. (I usually do most of my work with Zotero off-campus--no time when I'm on-campus.) The problem seems to be just with jstor.

    From home, I use a proxy. I sign in with my credentials and then, for example, go to the article here:

    http://proxy.ulib.csuohio.edu:2092/stable/4486409

    I'm wondering if this is a problem with Chrome and the proxy switching problems discussed above. I have not been brave enough to try any of the solutions discussed by d.bobak. I have tried to stop using Firefox for several reasons, but will go back to it if I have to to get full Zotero functionality.

    Thanks for any help!

    Thanks for any help.
    • CommentAuthoradamsmith
    • CommentTimeFeb 27th 2012
     
    I'm surprised that works with Firefox even.
    But yes - since jstor is not in the URL, the connector won't recognize the site as JSTOR and won't display an icon. In the short run there's nothing we can do about that - I believe there are plans to integrate the proxy feature in the standalone connectors, but I don't think that will happen soon.
    • CommentAuthorSimon
    • CommentTimeFeb 27th 2012 edited
     
    Only Zotero for Firefox can understand URLs that look like that. The Chrome and Safari connectors can only understand URLs like http://www.jstor.org.proxy.university.edu, which are more common these days.

    I think that Chrome 17 added the features we need to support proxies like yours, but it will be a little while before we port this functionality from Zotero for Firefox to the Chrome connector.

    EDIT: You might also see want if you can get VPN access to your university, which would allow you access JSTOR without a proxy so that the Chrome connector works.
    • CommentAuthorshel
    • CommentTimeFeb 27th 2012 edited
     
    Thanks for the responses. I'll speak to our librarians about it, but since the university has just signed a contract with refworks, I doubt they will care to help much. Sounds like I will either go back to Firefox--assuming it will work, given AdamSmith's response, I'm now worried about even that--or capitulate to our administration and use RefWorks instead of Zotero.

    Edit: I have used the beta and release candidates of standalone with Chrome and did not have this problem, which is why I thought it might have something to do with the 3.03. Guess not. Thanks anyway.

    Edit 2: Re-installed Zotero for firefox. No problem using it on my university library website. Jstor works again, thank goodness, though I don't like having to rely on Firefox.
  2.  
    I too would like to use Zotero with Chrome but given the response above will revert to Firefox until this can be fixed.
    • CommentAuthoradamsmith
    • CommentTimeMar 4th 2012
     
    @Barbara - it really depends on the specifics - what site & what URL are you looking at?
    • CommentAuthorqenghis
    • CommentTimeApr 1st 2012
     
    Hi Adam, with JSTOR, pdfs are automatically downloading for me, but with ProQuest, they are not. I haven't tested other sites.

    I'm using standalone 3.0.3 with Chrome 18.0. The same process works fine with the FF plugin.

    Thanks.
    • CommentAuthoradamsmith
    • CommentTimeApr 1st 2012
     
    we need to see actual URLs to say more. I believe proquest should typically work with Chrome.
    • CommentAuthorqenghis
    • CommentTimeApr 1st 2012
     
    • CommentAuthorSimon
    • CommentTimeApr 2nd 2012 edited
     
    qenghis: that ProQuest page won't work through a proxy at the moment, because the PDF is on a different domain from the page being saved. However, a workaround for this is next on my list.
    • CommentAuthorqenghis
    • CommentTimeApr 2nd 2012
     
    Thanks a lot! I look forward to the fix.
    • CommentAuthorTom Fish
    • CommentTimeApr 16th 2012
     
    I'm not sure if this is the same problem, but it seems closely related... I'm using standalone with Chrome, and when I open a pdf in the Web browser I no longer see the right-click option to "Save Zotero Snapshot from Current Page". These are not proxy server closed sites, but publicly available pdfs (e.g. http://www.affinity.org.uk/downloads/foundations/Foundations%20Archive/37_02.pdf ).

    It looks like Chrome displays a different right-click menu when displaying a pdf.
    • CommentAuthorSimon
    • CommentTimeApr 16th 2012
     
    Tom Fish, that's a different problem from the one described in this thread. Assuming you've checked that the connector is installed, try disabling other Chrome extensions (in particular <a href="http://www.zotero.org/support/known_issues#google_chrome_connector">Bookmarks Menu</a>, which is known to be incompatible). If you're still having issues, start a new thread.
    • CommentAuthorpentcheff
    • CommentTimeJul 8th 2012
     
    Yet another Chrome + Standalone with proxy "situation". This is on a Mac running Snow Leopard. Versions of other software: Firefox 13.0.1, Zotero Standalone 3.0.7, Chrome 20.0.1132.47.

    With Firefox, I can do a single click on the Zotero URL-bar icon to get reference metadata and PDF automatically downloaded. I use local storage for PDFs (well, actually a Dropbox directory symlinked to Zotero's "storage" directory).

    For some library access, I activate FoxyProxy in Firefox to redirect _all_ http traffic to a remote proxy. Whether the FoxyProxy proxy is active or not, the metadata and the PDF download (as reflected by metadata in Zotero Web and metadata+PDF in Standalone Zotero). Brilliant!

    With Chrome, the same thing works when I'm not using the proxy: single click on the Zotero URL-bar downloads metadata to Zotero Web and metadata + PDF to Standalone. Chrome > Preferences > Extensions > Zotero Connector > Options claims that "Zotero Standalone is currently available."

    When I fire up Chrome to use a proxy (using a commandline like: "open -a '/Applications/Google Chrome.app' --args --restore-last-session=5 --proxy-server=my.proxy.server.org:80"), things semi-break. Only metadata get downloaded, and only to the web database (I can see them in Standalone by clicking Standalone's refresh). No PDFs get downloaded. The Chrome extension preference for Zotero claims "Zotero Standalone is currently unavailable" (the "unavailable" becomes set the moment I validate to the remote proxy in the browser using Basic Auth).

    Note that this is all independent of clever connectors or magical autoproxying. This is using a bog-standard full-on proxy-everything. It doesn't matter whether the site is "open" (e.g. PLoS ONE) or protected (e.g. http://www.int-res.com/abstracts/meps/v458), though of course without an active proxy, I get no PDFs from protected sites under any setting.

    It looks as though the communication between the Chrome Zotero Connector and Zotero Standalone gets snapped when Chrome runs using a proxy.

    Any suggestions (besides "use Firefox":)? Thanks!
    • CommentAuthorSimon
    • CommentTimeJul 8th 2012
     
    Chrome needs to be configured not to proxy localhost. Try adding --proxy-bypass-list=127.0.0.1 to your command line arguments.
    • CommentAuthorpentcheff
    • CommentTimeJul 9th 2012
     
    Excellent suggestion — makes good sense. Thanks!

    And it gets us halfway there: the browser now "sees" the Standalone Zotero (it now claims "Zotero Standalone is currently available") and metadata get immediately posted to the Standalone copy. (Just for kicks I also tried "localhost" — that fails outright.)

    Still missing: PDF download from otherwise-protected sites. For example, on the Marine Ecology Progress Series site, "open" PDFs get downloaded but non-open ones don't (when the proxy is enabled).

    Speculating here: I'm assuming that the way things work is that the Zotero Connector signals Standalone to do the metadata-fetch and the PDF-fetch. So now the connection allows Zotero Standalone to grab the metadata (but the metadata are available proxy-or-not), but Zotero Standalone fails to grab the PDF since it doesn't "know" about the proxy. Since only the browser speaks through the proxy, Standalone gets only the metadata.

    So... elaborate the protocol between the two so that Connector could tell Standalone about the proxy? Or is the proxy information even available (explicitly) to the Connector inside Chrome?
    • CommentAuthorSimon
    • CommentTimeJul 9th 2012
     
    If you don't want to change your system proxy settings, it is possible to change the proxy settings in about:config. To get to about:config, open the Zotero preferences, click "Advanced" then "Open about:config". You probably want to set network.proxy.type to 1 and set network.proxy.http and network.proxy.http_port to the hostname and port of your proxy. See MDN for more documentation about proxy settings. If your proxy requires authentication, this may or may not work.

    I think it's now possible to get information about the proxy from the connector and send it back to Zotero Standalone, but the proxy configuration you have seems relatively uncommon, and it may be a little while before I can get to this.
    • CommentAuthorpentcheff
    • CommentTimeJul 11th 2012
     
    Yes, you're right: I don't want to change system proxy settings (in fact, for many of our users, they don't have the client rights to change system proxy settings).

    Doing the changes you suggest doesn't (quite) work. Same results: metadata download fine, PDF does not. Sniffing the wire traffic shows that the problem appears to be the password request by the proxy. Since Zotero Standalone doesn't/can't reply, the proxy comes back with a "407 Proxy Authentication Required" error instead of the requested PDF.

    How often have you wished that proxies could just go away, or at least that everyone would stop making clever innovative versions of them that you have to try to accomodate?

    Thanks for the suggestions — would love a solution, but you're right, this is probably a pretty unusual configuration. Though being able to respond to a Basic user/password request may not be unusual.
    • CommentAuthorpentcheff
    • CommentTimeJul 11th 2012
     
    Followup to my own posting: Having put in the network.proxy.http and network.proxy.http_port settings, then seeing Zotero Standalone fail to fetch a PDF since it failed to get a user/password validation to the proxy server, I stopped.

    However, I subsequently dropped a PDF into Standalone manually, then did a right-click > Retrieve Metadata for PDF. That popped up a user/password dialog box for the proxy, and subsequent retrieval attempts through the browser work (yay!).

    My take on this is that direct interaction with a PDF (or perhaps anything else that sends it out to the web) in Zotero Standalone will trigger a user/password dialog for a proxy that Standalone has been configured to use. Having the browser signal Zotero Standalone to fetch a PDF, however, fails to trigger the user/password dialog box.

    So... is there a way to make proxy user/password dialogs happen when Standalone is triggered by a browser? Or do I have to keep an un-metadata-ed PDF hanging around on my desktop to "prime" Standalone's proxy usage?

    Cheers!

Zotero Forums are powered by Vanilla 1.1.5a