LibreOffice plugin does not work under Ubuntu 10.04

I think this can be related to discussion:
"LibreOffice plugin does not work under Ubuntu 11.10"
but have tried the fix mentioned there and does not solve my problem.

My problem: I try to include a reference on a odt document (created on another computer with the same ubuntu ans same versions of the programs) with
LibreOffice 3.3.2
OOO330m19 (Build:202)
tag libreoffice-

using firefox 3.5. (3.6.24) under ubuntu 10.04, zotero 2.1.10
and plugin Zotero LibreOffice integration 3.5b3
and get a window with the following error (then I click OK and LibreOffice keeps on working, but Firefox gets frozen and have to kill its process):

An error occurred communicating with Zotero:

Thanks for your help

  • Cannot access that link, but can access:

    which I understand is the same one, isn't it?

    Anyway, I do not see the error message mentioned there is related to the one I get and just reinstalling the plugin as it mentions does not solve the problem.

  • Solved.
    I think I had a problem with a previous version of the plugin
    that was installed for openoffice.
    The problem was solved by:
    1. Uninstalling the plugin from firefox
    2. Uninstalling openoffice (not sure it was required, but it's normally done before installing libreoffice and I did not):
    I used
    sudo apt-get purge openoffice*.*
    as advised in
    3. Install the plugin from within firefox
    4. Start libreoffice: the plugin was not there. Close libreoffice
    5. In Firefox: Tools/Add-ons/Zotero LibreOffice integration/Preferences/Reinstall Extension
    6. Start libreoffice, the plugin was there and working.
    Not sure all steps were actually needed...
Sign In or Register to comment.