LibreOffice plugin does not work under Ubuntu 11.10

After reinstalling Ubuntu 11.10 over the holidays, I soon discovered that I'm unable to integrate Zotero into LibreOffice for whatever reason. I'm using the beta version of Zotero (3.0b3) and LibreOffice Integration plugin (3.5b3). The versions of the corresponding programs are: Firefox (10.0b2) and LibreOffice (3.4.4)

I actually remember experiencing a similar problem previously, and that was due to the fact that I was using the openJDK version of Java instead of the one provided by Sun (Oracle).

My worry is that since Ubuntu has now stopped providing the version of Java developed by Oracle, I might not be able to get Zotero to work with LibreOffice.

Yet when I looked at the following thread, < >, I find that LibreOffice plugin should now work with openJDK as well. If that is indeed true, then I'm not quite sure what is preventing me from integrating Zotero into LibreOffice.

Can anyone provide me with some help? Thanks!
  • edited January 4, 2012
    Well, I simply can't do anything with LibreOffice plugin. I can't configure the plugin to recognize LibreOffice under the Zotero preferences. LibreOffice of course does not show the Zotero toolbar. The plugin does not show up on the LibreOffice extensions list.

    There is no error to report, but the plugin does not seem to be functioning.
  • What more should I provide?
    I'm not receiving any error message, but the LibreOffice Integration plugin is simply not functioning. It used to automatically detect LibreOffice on the system, but now it's not doing that and I don't even see a way to manually configure it.

    I believe the older versions of LibreOffice plugin had the option to manually configure but it seems to be gone in the current version of Zotero + plugin.
  • It's still not clear what is happening - remember we can't see your screen.
    Do you see the toolbar in Libre Office? And when you click it nothing happens?
    If so, try this. If that's not it, you need to say in what way this isn't working.
  • > adamsmith

    Thanks for the response.

    No, I don't even see the toolbar. I simply don't have anything working despite having the plugin installed.
  • Ah, OK, that helps.
    You should be able to get to
    "Re-install Word Processor Components" (or something with a similar name) from Firefox --> tools --> add-ons --> Zotero Libre Office Integration---> Preferences
    or has that been removed for the new version of the plugin?
  • edited January 5, 2012
    Yeah, there's no longer a button I can click on in the new version. I can still access the option menu, but there is no button to manually configure the plugin.
  • edited January 5, 2012
    The current LibreOffice plugin doesn't support Firefox 10 beta, so it's probably disabled, which is why you don't see an option to install it. The next version will. For now, you could use Firefox 9, which is the latest stable version of Firefox.
  • But the fact is that I used to be able to use LibreOffice plugin without any problems prior to reinstalling my system, and I was also using Firefox 10 at the time as well.

    While I didn't do a good job at describing my issue, I can say that this is why I was led to believing that the source of my issue lies in Java and the fact that I now have openJDK installed rather than the Sun Java.
  • it doesn't have anything to do with Java.
  • edited January 5, 2012
    It's unrelated to Java. The installation code in the current released version of the plugin simply does not support Firefox 10. The plugin may have worked if you installed it under an earlier version, but it certainly won't install. You can try the dev XPI, which should work, although you may need to use the Add-on Compatibility Reporter to enable it.
  • Yeah I thought about trying that as well. But the link is unfortunately broken. Is there suppose to be a dev build available for LibreOffice? Both WinWord and MacWord seem to have the dev build but not for LibreOffice.
  • Sorry, should be fixed now.

    is the link to the trunk.xpi for the LO plugin.
  • Ok that resolved the issue! Thank you so much for your help!!!
  • Dear all,

    I just wanted to add that I had the same problem as areteichi on Debian Squeeze, running Iceweasel 3.6.26 and LibreOffice 3.4.3., word processor plugin 3.5.2.
    The link provided by adamsmith solved the issue.

    Thanks so much!!
Sign In or Register to comment.