Unable to move Zotero profile to new Firefox profile

My Firefox 2.0 crashed with something and could not be salvaged. I used the last resort -- to abandon ship, opened a new profile and copied everything I need to the new one.

But Zotero content refused to be copied. It just did not allow me to copy it to another folder.
Although I now have Zotero in my new profile FF, it is empty. My whole bibliography was not there.
What's wrong? Is there a special procedure to follow when doing this? (I've read the Zotero documentation on this, and it does not suggest so.)
  • What do you mean by "did not allow"?

    All Zotero data is stored within the 'zotero' folder within the profile folder. If you copy that to the new profile with Firefox closed, you should see all your data upon starting Firefox.
  • I tried to copy the zotero folder from the old FF profile to the new, and got this message:

    "Error copying file or folder:
    Cannot copy zotero.sqlite: Access is denied
    Make sure the disc is not full or write-protected and that the file is not currently in use."

    Of course I've made sure of those, but access is still denied.
    Have attempted for a few times, same results.
    The outcome is an empty Zotero in my new FF :(
  • There is a limitation in Windows that prevents copying open files and it can sometimes be difficult to see what has a file open.

    Close firefox & bring up the task manager to confirm that the program actually terminates. If you still have problems, either forcibly terminate firefox or restart your computer & try again.

    There are also a few "unlocker programs" that can tell you why a file is locked & can unlock them for you (by automatically trying the avove steps).
  • Okay, I've tried an unlocker pgm and it appears to be working -- the problem I first mentioned above does not appear again.

    BUT: a new (& very strange) problem arises, and I still cannot move my Zotero profile into my new FF profile ...
    in the middle of moving my Zotero profile, this error message pops up:

    'Cannot remove folder TypeclickFlightID22653AdID32165TargetID743Segments181373847867Ta: The filename or extension is too long.'

    I have no idea what it is, and don't know what I can do.
    I only know that the moving operation fails, again.
    I still have an empty Zotero, and my whole bibliography is unaccessible now :(
    Can anyone help?
  • edited February 4, 2008
    Find the folder and try to delete it manually. If that doesn't work, try renaming it first.

    You might need to use the command prompt if that doesn't work.
  • Yam
    edited February 9, 2008
    More strange things to come...
    Now that I have finally moved my Zotero profile into the new FF profile.
    Then I restarted computer and opened FF. I still have an empty Zotero -- there is absolutely nothing in my library.
    What have I done wrong? How to remedy??
  • I have successfully moved the whole Zotero profile to my new FF profile.
    I have also reinstalled Zotero, cleaned and restarted computer.
    BUT: when I open Zotero, it is all empty -- even though everything seems to be in the profile.
    Can anyone offer some help please?
  • What files are in the root of the Zotero directory, and what are their file sizes and time stamps? Is the folder named 'zotero' and located directly in the Firefox profile (next to the extensions directory, localstore.rdf, etc.)? When you go to the Advanced pane of the Zotero prefs and click Show Data Directory, do you see those files?
  • A folder named Zotero is directly inside the Firefox profile.
    ** But within that Zotero folder there is another one called 'Zotero' (exactly same name), beside a 'zotero.sqlite' (953KB) and a 'zotero.sqlite.bak' (also 953KB). **
    Inside this 2nd Zotero folder is a folder called 'storage', within which are numerous subfolders named by numbers (eg. 225,283, ... 16731, etc.)
    Size of these subfolders: varied -- ranging from 20 or 30 KB to a few hundred KB. Time stamps: all from the past 10 days or so -- the oldest seems to be Feb 4 (the day I first succeed to move some of the files), the newest is Feb 13 (the day when I posted the last message above).

    In 'Show Data Directory', I see the 3 folders mentioned above within the ** ** --- i.e. 'zotero' (the 2nd one, inside the 1st zotero), sqlite, and sqlite.bak.
  • zotero.sqlite, zotero.sqlite.bak, and 'storage' need to be directly within a directory named 'zotero' (lowercase), which needs to be directly within your Firefox profile directory.
  • I have taken away the redundant 'zotero', and now zotero.sqlite, zotero.sqlite.bak, and 'storage' are directly under 'zotero', which is directly within my Firefox profile.
    When I opened 'Show Data Directory', these 3 can be seen immediately.
    I have cleaned and restarted computer, reinstalled Zotero.
    But still, my Zotero library displays nothing.
    Something missing???
  • Are there errors listed under Report Errors under the Actions (gear icon) menu? If so, send in an error report and post the Report ID here.

    If not, we'll need debug output.
  • Error report sent.
    Report ID = 515087251

    Many thanks.
  • No Zotero errors in there.

    Disable all your other extensions and try again. If Zotero still doesn't show up, we'll need debug output sent to suport@zot....org.
  • I might have got something wrong with the instructions in debug output:
    I've set the extensions.zotero.debug.log to true, closed Firefox.
    But when I use Start - Run to restart FF, the following cannot be found:
    “C:\Program Files\Mozilla Firefox\firefox.exe” -console

    Did I get things wrong??
  • The path may be different on your system, but the idea is that you're launching firefox.exe with the -console flag.
  • I am completely lost now.
    I could not get to the -console by following the instructions in 'debug output' here in zotero.
    I turned to Mozilla for help. I was (sort of) told that there was no such thing as launching with -console flag (!!!)

    Can someone provide a dummies guide to this? My PhD submission deadline is coming, and I have an empty bibliography -- I am doing my footnotes from memory!
  • I turned to Mozilla for help. I was (sort of) told that there was no such thing as launching with -console flag (!!!)
    The person on that thread just thought you meant the profile manager, but the -console flag does exist.

    Close Firefox, right-click on the Firefox shortcut on the desktop, click Properties, and copy what's in the Target: box to the clipboard. It should be something like "C:\Program Files\Mozilla Firefox\firefox.exe", though it may be slightly different on your system. Then go to Start, Run, and paste that into the Open: field. Then add a space at the end and "-console", and hit Enter.
  • Yam
    edited February 20, 2008
    Got it all, thanks.
    Please excuse my dummy question, again:
    What should I actually send to support@zot....org? Everything in the console window?
  • Everything in the console window?
    Yes, please.
  • Just sent as 'debug output from yam'.
    Thanks a trillion.
  • PS: what am I supposed to do next?
  • PS: what am I supposed to do next?
    Check your e-mail.

    We need the output from right when you start Zotero and before you load any pages (or even open the Zotero pane).
  • Yam
    edited February 20, 2008
    um... I'm not sure I understand what you mean. :p
    You mean I should run and send another output?
  • Sent again as 'debug output from yam (2)'
    This time I started FF with a blank page and have not opened any other pages (including Zotero pane). Hope it helps.
  • So, after two weeks, can anyone enlighten me with some hints? Does it mean that my zotero library is gone forever?
    If that is the case, I'll just dumb the profile and start a new one from scratch (which means of course I'll lost a lot of things -- all of my notes, etc.)
    Seems that I am the only person in the universe who have experienced such problem.
    In the mean time, I've tried to move the zotero profile back to the old Firefox profile, nothing helps. And I dared not add new things to zotero lest I mess things up further.
    Would there be something missing from my zotero profile -- eg something lost during the initial moving process? What could that be?
  • Yam: We've responded to all of your e-mails, including your e-mail from the 24th asking why we hadn't responded. If you haven't received them, something is wrong with your e-mail account or they're ending up in your spam folder.

    I responded to your e-mail with the debug output ten minutes after you sent it on the 20th:
    OK, now go to the directory in the first line:

    C:\Documents and Settings\Administrator\Application Data\Mozilla\Firefox\Profiles\ybs0s89u.newprofile2008.1.31\zotero

    What files and folders do you see there? Is that the folder to which you moved your old Zotero files?

    Close Firefox, copy the zotero.sqlite file in that directory to the desktop, and upload the copy to the DB repair tool at http://www.zotero.org/utils/dbfix/. Then send us the Upload ID it provides. (You can ignore the download links it provides.)
  • Hi Dan,

    Really thank you for this.
    The files I see there are the ones I moved.
    And I've uploaded and sent in the upload ID.
    Also, please accept my apology if you or anyone in your team feel offended. I didn't mean to.
    It was really strange that I did not receive both of your emails. (I ave received zotero mails before with no problem.) There could be a problem with my account. I've reset it and make sure all zotero mails go to my inbox and nowhere else.

    Thanks for the response above, it means a lot to me.
  • Yam: There are only six items in the library you uploaded, and no notes.

    So if you're expecting there to be more than that, you didn't copy the old files to the right location.
Sign In or Register to comment.