Secure Connection Failed

Hi *,

I'm using 3.0b2.1 together with the Chrome connector. Now, when I try to safe a reference to zotero, I want the pdf to be associated with the reference automatically (meaning the pdf should be downloaded and attached to the entry). This worked fine with zotero for firefox. Now, it seems like zotero standalone tries to download the pdf but fails because of some certification issues:

The error message basically says: uses an invalid security certificate

The certificate is not trusted because no issuer chain was provided


Now, is there a workaround so that the autosave option works again or do I need to contact someone at my university to update the certificate?

  • I may add that I was able to reproduce this on another PC with WinXP and the same version of zotero and chrome.

    Is this a known error in zotero standalone? Perhaps it has to do with the ezproxy used by my university or chrome?

    Thanks for the feedback!
  • Your EZProxy doesn't have a valid certificate, which means that the connection is supposed to be secure but that it can't be verified as such. At the moment, we don't have a way of disabling this protection. The best solution would be to get your university to use a valid certificate. This page has some more details that you could forward on to your network administrator; it seems they should be able to get one for free.
  • Thanks Simon.

    I contacted the school and they confirmed that the certificate is valid. I also confirmed this by loading the site in Chome directly ( However, Chrome indicates that it has problem with the page:

    "The identity of the website has been verified by InCommon Server CA" but goes on by stating "this page includes other resources which are not secure"

    So it seems that the certificate is fine... maybe Zotero takes issue with the Chrome statement that "this page includes other resources which are not secure"?

  • Well, the message means what it says. It's probably the linked CSS file, which is currently served over HTTP. They need to serve that over HTTPS.
  • edited January 19, 2012
    I also get this error. Why is there not an option to bypass this check, this is frustrating. I use a full legal way to obtain articles, and then this happens...
  • If you provide an example we may be able to tell you specifically what the problem is, but you should talk to the site admins. The message means the site is broken, and you'd likely get the same error if you viewed the site directly in your browser.
Sign In or Register to comment.