[CSL STYLE ERROR: reference with no printed form.].

I have the 2.1.10 version of Zotero for Firefox, with the plugin for Microsoft Word as well.

For any *repeated* reference in my word document I get the following error (appearing where the footnote information should appear):

[CSL STYLE ERROR: reference with no printed form.].

For any new references it is not a problem, but as soon as a reference is used more than once it displays this.

I have already tried copying and pasting the document content into a new document to see if the problem goes away.
I have also clicked on the “Set Document Preferences” button.
I have also saved my document as a 1997-2003 word document instead of a doc.x with the hope that it was that, but it wasn't.

Any ideas?
  • edited November 15, 2011
    Are you using a customized style? If not, try reinstalling your style from http://www.zotero.org/styles .
  • I'm using the Modern Humanities Research Association with bibliography.

    I've reinstalled it but it still comes up with the error.
  • Try changing styles. Start with Chicago Manual of Style. If that still doesn't work, try something completely different.
    This is for troubleshooting only, obviously MHRA should work, but it will be helpful to know if the error is specific to the style you're using.
  • I changed it to Chicago Manual of Style with bibliography, with meant that the repeated footnote came up as 'Ibid.' as expected.
    Yet when I changed it back to Modern Humanities Research Association with bibliography, it still comes up with the same [CSL STYLE ERROR: reference with no printed form.].
  • the only way I can reproduce this is for an item without author and page range - is that the case here?
    We should probably try to fix that.
  • if this is indeed the problem I just fixed it.
  • Hi, I just checked and yes, it was for an item without an author or page range (was a webpage).

    I have refreshed Zotero in the Word document, but nothing has changed. Do I need to re-download the Zotero word plugin in order for the changes to take place?
  • edited December 5, 2011
    not the word plugin, no, but the MHRA style from the repository. Sorry, I should have mentioned that (though I thought I did in your other post wrt to the final period).
  • Sorry, I don't understand where to find the 'repository'?
  • It has now worked having copied and pasted my text into a new document, set doc prefs and then pressed 'Zotero refresh'.
  • In an existing document, a newly-installed version of the currently selected style will take effect when you switch to another style, then switch back. It's a little wrinkle that catches a lot of people; would be nice if Zotero could trigger reselection of the style in session documents when a new version is installed.
  • @adamsmith:
    How did you fix it? I have the same Problem with my style "HWR Berlin".
  • Difficult to say without more precision. Thus, as adamsmith wrote (in this thread):
    Try changing styles. Start with Chicago Manual of Style. If that still doesn't work, try something completely different.
    This is for troubleshooting only, obviously MHRA should work, but it will be helpful to know if the error is specific to the style you're using.
  • edited June 6, 2012
    @staniko: It looks like HWR Berlin will throw an empty cite for the first reference if the item has no author, editor, translator, or year. I guess the first question would be whether you are sure that the details for the item are correct. If the answer is yes, I guess the second question would be what should appear if those details are all missing?
  • @fbennett: This error appears when there should be an Ibid.
    But if I give this Ibid a page number, there is no such error.
  • edited June 7, 2012
    I fixed it. I changed

    <if position="ibid">
    <group delimiter=", ">
    <text term="ibid" text-case="capitalize-first"/>
    <text macro="point-locators-subsequent"/>


    <if position="ibid-with-locator">
    <group delimiter=", ">
    <text term="ibid" text-case="capitalize-first"/>
    <text macro="point-locators-subsequent"/>
    <else-if position="ibid">
    <text term="ibid" text-case="capitalize-first" suffix="."/>
  • edited June 7, 2012
    Ah, quite right. I hadn't spotted the grouping issue, sorry. A slightly simpler (but less transparent) way to prevent the ibid term from being swallowed would be:<group delimiter=", ">
    <text term="ibid" text-case="capitalize-first"/>
    <text macro="point-locators-subsequent"/>

    (The reason being that a term is suppressed within a group only if another rendering item attempts to render a variable and fails. With the extra group wrapper, the term has no variable-rendering partners within the inner group, so it will never be suppressed. The outer group will see that the term has already been rendered, and won't suppress the content of the group even though the page locator variable is empty and fails. It makes sense once you get your head around the implicit conditional logic of group elements.)
  • This problem could also be solved by excluding terms that typically are used independent of any variable content from group-suppression, such as "anonymous", "forthcoming", "ibid", "in press", "internet", "interview", "letter", "no date", and "online". Not sure if that's a good idea, though.

    Alternatively, I could extend my quality control script to screen for styles that are vulnerable to this problem, although I'm not sure if that's easy to code.
  • Hey!
    The same Problem occures with the TU Wien and the TGM Wien Styles...
  • @fbennett, I know you've been trying to eliminate white-space from affixes, but in this case, wouldn't the following be a more logical solution?

    <if position="ibid">
    <text term="ibid"/>
    <text macro="point-locators-subsequent" prefix=", "/>
  • No objections, it's valid CSL.
  • Same issue with Bluebook style 2. Any thoughts.
  • that's likely a different issue. I'd just not use Bluebook 2. While neither of the bluebook styles is very good, the first one is better in almost every way.
  • That was my suggestion too. I hope switching versions will help.
  • Hi. I am now having this problem as well. I have tried switching to different styles but that did not help. I am trying to use the Modern Language Association 8th Edition. Any suggestions? Thanks.
  • I haven't been able to produce an empty cite with that style. A couple of questions:

    1. What is the item type?
    2. Does the item have no title, or no author?
  • It is a webpage and has both a title and an author.
  • Definitely not a style problem. MLA 8 does fine for webpages with just title and author.
    Could you right-click on that item in Zotero --> Export --> Zotero RDF (no notes or files), open the file with a text editor (Notepad, Textedit) and paste all its contents to gist.github.com --> Create public gist (you won't need to register) and post the URL here?
Sign In or Register to comment.