Zotero Word plugin bibliography sorting

After a lot of cursing I found out that the sorting of the bibliography entries in Word 2007 (currently 3.1.4 & 2.1.10 zotero plugins, but worked the same in the older versions) is influenced by the "Language for non-Unicode programs" settings in Windows 7 (not sure about other win versions).

Example: In Czech "ch" is a single letter following letter "h" in the alphabet. But obviously when writing an English paper, I want to have authors starting with "Ch" among those whose name starts with "C". The only way how to achieve it is to change the above-mentioned language settings to English, which requires a reboot and causes a lot of trouble with other software.

Am I missing something? Would it be possible to sort according to some other settings which would be easier to change? Thanks!
  • so setting the bibliography export locale doesn't change this?
  • It doesn't, already have it changed to en-US.

    Btw when looking at "My Library" in Firefox and sorting by Creator, the items are also sorted according to the Czech locale. But this is no big deal.
  • In Firebox, the processor should be calling an applicationLocale() method to the sort collation, and I think that should be grabbing the Firefox locale. This isn't quite right; when default-locale is set in the style itself, the collation should be based on that instead.

    I think Simon is planning to offer some locale selection options in the UI. To avoid confusion, I'll wait until that's been worked out before making adjustments in the processor.
  • So, do I understand it correctly that there is no way how to deal with it now? Other than via the above-mentioned windows settings?
  • Any development on this issue? Is there anything I can do to help to resolve this problem?
Sign In or Register to comment.