zoteroOpenOfficeIntegration doesn't open port?


I'm pretty sure that Zotero isn't opening up a port to talk to OpenOffice on my system (Ubuntu 11.10, recent firefox 8.0ish, Zotero Standalone 3.0b2.1). The debug id is 1687057814. The phenomenon is still as described here:

Though I'm pretty sure that for a while things were working, so I wanted to submit a new bug. The relevant error seems to be:

(3)(+0000126): ZoteroOpenOfficeIntegration: Not initializing communication server

I'm not sure what's causing that, though. netstat -ltpn shows nothing running on 50001, so i don't think hte problem is osme kind of a block.

Thanks for you help, as always!
  • edited November 8, 2011
    The error is pretty generic:
    [JavaScript Error: "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIServerSocket.init]
    Something is blocking Zotero from binding to that port.
  • so, I tried moving .zotero of the way and reconfiguring zotero-standalone, and the problem went away. Next, I moved the old (broken) .zoteor back into place, but deleted prefs.js. After some complaining (mostly about the data directory) zotero started fine and, again, seems to be working perfectly. And finally, I just tried deleting all the references to zoteroOpenOfficeIntegration from the original prefs.js file and, ta-da, everything seems to be working again.

    It looks to me like there was some mismatch in the prefs file, not really accessible from the zotero GUI, that was incapacitating the service from loading.

    Is there a troubleshooting page i can add this to, n case other people are suffering from the same thing?
  • ah, and was just looking a little closer at the prefs file, and saw this:
    > user_pref("extensions.zoteroOpenOfficeIntegration.sofficePath", "file:///usr/lib/openoffice/program/");

    this preference must not have been reset when I switched from openoffice to libreoffice. Is this a known problem?
  • That path is left over from an older version of the plug-in. The new plug-in no longer uses it.

    The only thing that deleting the preferences would accomplish is to force the LibreOffice component to be reinstalled, which shouldn't have an effect on that error. It's more likely that something that you did inadvertently fixed it.
Sign In or Register to comment.