Error while installing Chromium extension: "Package is invalid: 'CRX_FILE_NOT_READABLE'."

I just clicked on the Chrome extension to install it in Chromium in Ubuntu Linux and I immediately got the error "Package is invalid: 'CRX_FILE_NOT_READABLE'." Is this a problem with the extension or with my setup? I'm assuming that Chrome extensions are supposed to work in the open-source Chromium browser.
  • Yes, the Chrome connector works with Chromium - I just tried installing it in Chromium on Ubuntu 11.10, also had it working under 11.04.

    Try the usual stuff: restart chromium, clear cache, try a different network etc.
    Also, to be sure, you're downloading from here, right?
  • The above suggestions by @adamsmith don't work with Mac Lion O/S and latest version of Chrome. Same error after restarting, clearing cache, etc., namely "CRX_FILE_NOT_READABLE." Safari does work. So what next?
  • see here:
    and follow up on that thread with any further questions.
This discussion has been closed.