Your WebDAV server must be configured to serve files without extensions and files with .prop extensi

Hi there, I'm using the WebDAV service provided by Recently, I get the following error message:

Your WebDAV server must be configured to serve files without extensions and files with .prop extensions in order to work with Zotero.

I read in this forum that this is a server issue... the service support told me that they can access their WebDAV service via zotero. Now, I'm not sure if they use a different version of zotero and get different results.

Can someone confirm that the above mentioned error message definitely refers to the server config?

  • Provide a Debug ID for a verification attempt that produces that error and we should be able to confirm the problem.

    What version of Zotero are you using?
  • Debug ID: D1653166455

    I'm using 3.0b2.1 standalone.

  • Just to follow up: Did the Debug ID help with narrowing down the source of the problem?

  • It's definitely a problem with your WebDAV server—it's returning a 204 success code when Zotero uploads a file and then returning a 404 when Zotero requests that same file immediately afterward—but I made a small tweak to Zotero's upload code (saving a file with "1" as its contents instead of " ") on the off-chance that it works around the problem. The change will be available in the next 3.0 release, or you can try the trunk dev XPI of Zotero for Firefox pointed to your Standalone data directory (with Standalone closed). The trunk XPI should be fairly stable right now since it's about to be released as the next beta, but make a backup of your data directory for good measure and switch back to 3.0b2(.1) afterward.

    But it's a bug in your WebDAV server, so if you're not comfortable doing the above then you should just talk to them.
  • edited November 5, 2011
    Thanks for the reply. I forwarded this message to the support team. Let's see if they can solve the issue.

    Thanks again
  • I'm getting the same error through It's strange because it has been working perfectly for the past couple of years and I have a ton of pdfs and such stored on there through zotero. Now I can't access them any more, and I don't understand why. I was wondering if it might be a linux issue, since I recently switched to Fedora 15 from Windows 7, but you all say it's a server issue. Did and this servers suddenly change something at the same time to generate this error? Very strange to me....
  • jmtrombley:
    I am also getting the same problem through I find it is related to the version of Zotero. My zotero v2.0.9 with firefox 3.6 works with perfectly. But when I upgrade the zotero to v2.1.10, no matter which version of firefox.(I have tried 3.6 and 8.0) It gives me such message.

    Your WebDAV server must be configured to serve files without extensions and files with .prop extensions in order to work with Zotero.

    And when I manually login to the dav server. I find the files without extensions and files with .prop extensions can get download and upload well. So I feel it is a bug in zotero itself. Hope someone check it.
  • edited November 14, 2011
    brushington: I've already reviewed the debug output for a user. The server behavior is broken. This is not a bug in Zotero.

    We might be able to make future versions of Zotero work around this, but making Zotero work with broken WebDAV servers is really not a priority. We provide Zotero File Storage for users who don't have access to a properly functioning WebDAV server (or who want the extra functionality Zotero File Storage offers).

    2.1 uses a slightly different WebDAV sync method from 2.0 that actually makes it more compatible with (broken) WebDAV servers and restricted networks, but a badly behaving server might prefer one method over the other. On properly functioning servers they'll work identically.

    For the record, here's an excerpt from ssauerw's output above:
    (3)(+0000000): HTTP PUT ' ' to


    (3)(+0000000): ===>204<===(number)

    (3)(+0000000): HTTP GET


    (3)(+0000000): ===>404<===(number)</pre>
    A WebDAV server should never return a 404 for a file immediately after it was created (indicated by the 204). But these providers aren't in the business of providing WebDAV service, so it's not really that surprising that their implementations aren't entirely correct.

    Possible workaround: The problem might just be that there's a delay before uploaded files are available, which would be a problem for the server verification but possibly not for a normal Zotero file sync. You can try going to about:config in the Firefox address bar (or clicking "Open about:config" from the Advanced pane of the preferences in Standalone) and setting to true, which will override the server verification and let you try to sync. No guarantees, obviously.
  • The workaround fixed the issue for me. Thanks!
  • Yes, this workaround fixes the problem with Thank you!
  • This workaround worked for me too. I am using

    Thank you!!
  • Worked for me too, though "verify server" still returns the same error - as long as I can get my files, it's not an issue. :)
  • works for me too. Seems like building in a one sec time delay in the verification would be a non-trivial thing to do.
  • The workaround also worked for me.
  • Thanks for the workaround - got it working now with WebDAV.

    I do believe that adding a small delay between HTTP PUT and HTTP GET should be enough to pass server verification.

    Thanks for this great add-on.
  • I've created an issue for this.
  • I also have the same problem to use And frustratingly, setting to true doesn't work for me.
  • Note that even with the workaround the verify server button will not work, but the files should be synching.
  • @aurimas,

    Actually I checked my - it's not synced. Did I miss anything?
  • Since there's a chance this will occur with any cloud storage service backed by Amazon S3, in Zotero 3.0.13, now available, the server will pass verification—with a warning message—if the uploaded test file doesn't exist immediately after uploading, allowing you to attempt to sync.
Sign In or Register to comment.