Modified citation style no longer works in Zotero 3.0

Hi, I upgraded to Zotero 3.0 beta and it works fine, but the modified citation style I use is now not recognised as valid by Word. However, when I follow the steps to validate on, it is recognised as valid and it also is recognised by Zotero Reference Pane. The same style continues to work fine on my work computer, which hasn't yet been upgraded to Zotero 3.0 beta.

I checked the forums and couldn't find anyone else having the same problem, except for one person who said he'd deleted the URL by mistake. Mine is still there.

I tried posting the code on github, but for some reason my account isn't working. The file is at
  • As a matter of principle I'd set the rel="self" link to the same address as the id - though I don't think this would actually affect whether this works or not - but a good idea to exclude all possible errors.

    I can confirm that your style is valid and should work - what error exactly are you getting?
    Can you create an error report and post the ID here?
    In Word, have you tried to switch to a different style and back?
  • edited October 28, 2011
    You might also want to try removing the escaped ">" ("& gt;", without the space) from the first author's name.

    <name>Joyce Chia& gt;</name>
  • This is weird, I thought I replied to this earlier. I've tried both suggestions, neither of which worked. I then used TextWrangler to compare it to another custom style I'd made, which still works, and I changed everything that I could see that might affect it. Still doesn't work. The error I get is in Word (not in Zotero) saying that "The style you have selected does not appear to be valid. If you have created this style yourself, please check" that it validates or use another style.

    All the other styles I have work; for the moment, I'm just using my other computer where the style still works. A real mystery.
  • The link no longer works. Could you put the style up somewhere so I can download it and take a look? The error you see is normally triggered by a processor crash. If that's happening with a valid style, some fix may be in order.
  • Apologies - I was fiddling around with my Dropbox account yesterday and forgot I had put the citation style in that folder. Here's the link again:
  • edited November 7, 2011
    I fixed up the validation errors, then ran it in multilingual Zotero, which should be functionally equivalent to Zotero 3.0beta for this purpose. It seems to run just fine.

    I think the missing version attribute on the cs:style node would have prompted Zotero to attempt conversion from CSL 0.8.1 to CSL 1.0, which would have made the style crash.

    (Edit: for reference, the style node should include version="1.0".)
  • Thanks a lot for your prompt response! I'm on the wrong computer to test this out right now, but will do so tonight and report back. Thanks also for the hints about what to change for future styles.
  • Unfortunately the file itself doesn't appear to have changed - probably due to Dropbox which I had problems with today. However I tried including the version number as you suggested. This validated on but still didn't work. I also tried copying some headers in styles that are working on my computer, but again, nothing. I'm not sure what other validation errors you picked up fbennett - I've been ticking 'be lax' box and perhaps you've fixed something there. Otherwise, I might just try modifying some styles that are working on my system - it could work out faster as I don't think I made that many changes. Thanks to all, however, for your help!
  • Sorry I should have mentioned that the updated style version is still at the same URL link - for some reason when I included this URL this forum picked up some error.
  • the "be lax" box has to be checked. The style is valid.
  • edited November 8, 2011

    I hadn't looked at the content of the style, but now I see that it's a version of the AGLC. I'm working on an integrated set of legal styles that will allow on-the-fly switching between styles, with uniform metadata. The metadata layout is still in development, but if we can settle on commonly agreed conventions, it should lift things across the board -- for users, and for publishers and aggregators that provide legal content.

    Are you involved with either of the law review boards behind the AGLC? I've written a couple of times to confirm that there are no objections to implementing the style, but not yet received an answer. I assume that there's no problem, since the style manual is distributed free to the Web, but I'm working on a guidebook for the finished (Zotero for Law) system, and my publisher would like the comfort.

    On the technical issue, the style should run if the version attribute is correctly set. Have you tried deleting the old version from Zotero completely, then reinstalling with the valid copy? The old broken version would have the same ID, and that might be blocking the upgrade somehow.
  • Thanks Frank. Apologies for the slow response - somehow this must have missed my inbox. I still haven't figured out what exactly was wrong - I did try reinstalling it and changing the version. In the end I just copied across my edits to the style on to the Australian Legal Citation Style, which has worked (phew!)

    Love the sound of the integrated set of legal styles - I wish legal referencing wasn't so complicated (especially when you're doing comparative work).

    I'm not actually on the board of the law reviews any more (having graduated eons ago), but I was in fact on both the boards of the law reviews at the time the AGLC was originally developed, and am still in the Faculty so am in contact with the editors. I can certainly contact them to ask them again if they object, but I can't see why they would, since this actually assists in their object of uniform citation.

    I'll let you know how I go.
  • A note about getting "The style you have selected does not appear to be valid..." error even after the style passes validation on

    In my case, was not able to correctly check that the macro I was trying to use in <text macro="foo" /> was declared. The check is implemented in the schema definition, but does not seem to be able to perform it.

    While this is not necessarily the solution, if you're in this situation make sure that all of your macro names are spelled correctly and that the macro has been declared.
  • It's a known limitation. As far as I know, checking whether all called macros exist cannot be verified with regular RELAX NG schema. The embedded Schematron rules in the CSL schema that check for this are ignored by Jing, which is the validator used by

    One workaround is to extract the Schematron rules and run them separately. See e.g.
Sign In or Register to comment.