Sync problem

I receive an error message when zotero tries to sync. It says: "getfile() can only be called on attachment items."

I have absolutely no idea what that means, or any idea what item it is referring to.

Here is the Error Report ID: 190335120.
  • Check your database integrity in the Advanced pane of the Zotero prefs.

    If it passes, provide a Debug ID for a sync attempt that produces the error.
  • I've also been receiving the same pop-up error message: "getFile() can only be called on attachment items". This comes up when I click on the red "exclamation" circle (next to the "sync" circular arrow) which appears after Zotero attempts to sync.

    This seems to happen when I open Zotero after having made changes in my library on a different computer. Then, a few minutes later, the error seems to correct itself -- Zotero syncs normally and the red exclamation circle disappears.

    Database integrity check found no error.

    In case this helps with debugging, I've generated a Report ID from the most recent incident: 212629625.

    Thanks very much!
  • jcc: We'd need a Debug ID, not a Report ID.
  • Dan -
    The Debug ID is D1059209043.
    Thanks again.
  • That debug output includes the error? I don't see any errors in there.
  • Hello,

    Just in case, I found the same error twice; the second time I generated an eror report, it's id is 908406697; then I found this thread, read jcc's post, tried again and sync went OK. I have manual sync selected in this computer, and I haven't seen this before. Check integrity did not found any errors.


  • Dan, I just managed to replicate the error and generate another debug ID: D249264874. Hopefully this one is useful.

    (Again, this doesn't happen every single time, and only when I first power up Firefox and Zotero. After "warming up" a bit subsequent syncs usually go smoothly.)

    Thanks again very much.
Sign In or Register to comment.