Error reported when WebDAV server uses self-signed SSL certificate (report 643779701)

Hi there,

I got an error when first syncing my papers collection with Zotero 3.0b2.1. As written, I entered the WebDAV adress in Firefox, accepted the certificate, and did the same in Safari (default browser), which already had it accepted. Still, when clicking "verify server", I got the same error, although the reference collection seems up to date. It's in report 643779701.

Can Zotero Beta standalone operate flawlessly along with standard, Firefox-based Zotero?
  • edited November 5, 2011
    Whitelisting the certificate in Firefox or Safari has no effect on Zotero Standalone.
  • Actually, paux's manual copy of cert_override file worked for Zotero standalone 3.0b3.2. So, the workaround provided here works, but not what is suggested in the dialog box. I guess most efforts are put in the development instead of ergonomics.
  • It looks like the "Load WebDAV URL" isn't working properly in 3.0b3. It's supposed to load the URL in a built-in browser within Standalone that lets you whitelist a self-signed certificate the same way you've always been able to in Firefox, but instead it's just loading it in an external browser. We'll fix this for 3.0RC1.

    As an aside, though, if something isn't working for you and you'd like it to be fixed, it'd be in your interest to tell us that in a way that's actually helpful. You can make snide comments, or you can help us improve Zotero. But if using software with a few rough edges bothers you and you don't want to help smooth them out, you probably shouldn't use beta software.
  • I gave a report number in the first post, but didn't thought of updating the report since 1) I was in the middle of a project and, as advised on Zotero standalone download page, I didn't want to risk anything by using beta software. However, I had a pretty good experience in stability using Zotero's beta versions, so fears may be unjustified in this regard.
Sign In or Register to comment.