After creating parent item, item type cannot be changed

this is a minor bug, that both happened in 2.1.10 and in 3.0 with Mac OSX 10.6.8, ff 7.01. When creating "parent item" from pdf it produces as an item type "webpage". However, I often need to change this, but after changing the item type, although the item type name displays a different item type, say "report", but the fields remain those of the item type "webpage", i.e. it displays "website title" and "website type". The only way to change the item type then is to open zotero full screen in a new window, then suddenly the correct fields display.

  • Works fine for me. Provide a Report ID.
  • I should note this happens with the Schubert pdf plugin. maybe there is a problem with the plugin?

    Report ID: 622695789

    screenshot proof:
  • The PDF plugin shouldn't have any effect.

    That screenshot link isn't working for me.

    There are no relevant Zotero errors in there. Can you restart Firefox and provide another Report ID and a Debug ID for this (the whole operation, with Create Parent and the item type switch)?

    Does this happen for all items or just some?

    It's unlikely to affect this, but have you tried disabling other Firefox extensions?
  • it always happens.
    Report: 2019648385
    then another try, with debugging on

    debug ID: D648694391

    try the weblink again now.
  • I'm still not able to reproduce this, but since 2.1 isn't getting any further development, you should let us know if you're able to reproduce it in a 3.0 build—either with the 3.0 Beta or once 3.0 Final comes out.
  • edited October 18, 2011
    he says
    that both happened in 2.1.10 and in 3.0
  • Ah, sorry. See if it happens after the next 3.0 Beta (or try the trunk XPI, which should be safe to use right now, and switch back to 3.0 afterward).

    Since others aren't reporting this and I'm not able to reproduce it, there's something specific about what you're doing, so you may need to try to find a pattern to it.
  • Actually, I can replicate this with the most recent available trunk built:
    3.0b2.r10656 on FF 7.0.1 Ubuntu 11.04 all other add-ons disabled.
    Again, steps to replicate:
    1. Take any item (e.g. Journal Item Type) and change item type (I tried Book and Patent)
    2. OK the warning about deleted fields
    --> The item type will be changed, but the fields will not (as in miggug's screenshot above.
    This actually does create an error:
    [JavaScript Error: "uncaught exception: '12' is not a valid field for '2' in ItemFields.getBaseIDFromTypeAndField()"]

    3. Switch away from the item and back and now the correct fields appear.

    Let me know if you need anything more.
  • OK, I was able to reproduce that, and it should now be fixed on the trunk.

    This was due to a recent trunk change, though, so I don't see how it could've been happening in 2.1.10.
Sign In or Register to comment.