Workaround to disable spell checker

In the current Beta version of Zotero Standalone it is, as far as I know, neither possible to change the language of the spell checker to anything other than English, nor to deactivate it completely.

So when you write notes in a language other than English, they get very hard to read, because every single word gets underlined red.

I found this workaround for the situation, which I like to share: In "about:config" (Zotero Preferences/Advanced), set the value of

"extensions.spellcheck.inline.max-misspellings"

to "1".

Then the spell checker stops checking after the first wrong word. Don't set it to zero, it has no effect then.
«1
  • Thanks for the workaround. I don't know how straightforward it would be to add more dictionaries, but there should be a visible preference to turn off the spellchecker until this can be fixed at the root.
  • This has been driving me crazy for some time, now, and the solution has been around since September!

    I guess I need to hone my forum-searching skills!

    mreiter, you ROCK!

    And, um, thanks to longtalker's ill placed, and since removed post, I found it!!
  • We should probably just disable spell checking in Standalone for now. We could limit it to the English locale, but given that you can't access the menu options anyway (to disable, ignore words, etc.), it might be better to just turn it off until it actually works properly.
  • Dan Stillman, would it be so complex to add a checkbox to the preferences to enable/disable the spell checking? That way, people who write notes in English would not lose a feature and everyone else could easily turn it off.

    If it's too complex to implement it this way in the short time, I would agree that disabling it completely would be an improvement compared to the current situation, for everyone writing notes in a language other than English.
  • It's not really a feature. Zotero has never officially had spell checking support. In some contexts (tab mode and Standalone), Mozilla's spell checking just makes it through in a partly broken way. So I don't think we'd add a pref for this, since it's not supposed to be there at all.

    Out of curiosity, are you using the English locale of Standalone or another locale?
  • To be honest, I never thought about this. If you tell me how to check it, I can do that and tell you more then.
  • edited February 21, 2012
    Are your menus and buttons in English or another language? I'm just asking to see whether, in your case, disabling spell checking in non-English locales would have made this a non-issue.
  • Oh, I use English menus.
  • I, too, am using English ZSA, and the problem was when I was working with Spanish notes. I think disabling non-English locales would have worked for me.
  • arggem: Doesn't sound like it. "Locale" refers to (essentially) the UI language. So if you're seeing English menus, you're not using a non-English locale.
  • Oh, duh. I misunderstood (obviously)... I was thinking 'non-English locale" somehow morphed to mean the non-English in my notes...Nevermind.
  • better set

    "extensions.spellcheck.inline.max-misspellings"

    to "-1" (note the minus sign), so you have no spell checking at all,
  • Thanks for the -1 hint. This is hacky: spellcheck should either be supported completely or not at all. For academic work, I prefer it off, take responsiblitity for my own pselling :)
  • I am using Zotero stand alone with windows7 with a french (AZERTY) keyboard. Zotero's menus and buttons are in French, I mostly write in French.
    Using "-1", "0", "1" I get the same result: the first word of every paragraph is underlined.
    So it seems that Heinrich's trick does not work, at least for me.
    (it is much more readable with only the first word underlined nevertheless)
  • bakaneko: That's strange because I've exactly the same configuration and it works. The language doesn't matter here.
  • I write in German, so it was really helpful for me to use the workaround ("extensions.spellcheck.inline.max-misspellings" to "-1") in order to disable the spellchecking completely. Thanks!
  • I'm just wondering - this problem has been acknowledged for 2 years now and has not yet been fixed. The workaround works for me but still I had to do some searching before I found it. I wasn't even sure if this was Zotero's or my Mac's spell checker that caused the red underlining. So why not remove the spell checker completely? I agree that everyone able to use this program should be able to check their own spelling. Plus the academic community does include many languages other than English.
  • this is why:
    It's not really a feature. Zotero has never officially had spell checking support. In some contexts (tab mode and Standalone), Mozilla's spell checking just makes it through in a partly broken way.
    the spell-checker is a "side-effect" of the platform (Firefox/xulrunner) on which Zotero is built - Zotero just uses that as is, it's an extraordinary amount of work to make specific changes to that.
  • I understand. Would it be an option to add a checkbox to the preferences to enable or disable the spell checker? What this checkbox could do is simply what the workaround does: set the value of the line "extensions.spellcheck.inline.max-misspellings" in the "about:config" to "-1" or to "500" respectively. That way all users working with other languages could disable the spell checker without having to search the internet for a workaround and without having to manipulate the "about:config" themselves.
  • adamsmith:
    the spell-checker is a "side-effect" of the platform (Firefox/xulrunner) on which Zotero is built

    Well, I hope developpers take advantage of it and offer users the spellchecking extensions previously installed in Firefox (at least using the tab mode).
  • @mreiter. thank you very much. you have saved me from a lot frustration.
  • Thank you very much!
  • I'm using Mac OS Sierra and I am having trouble finding the "about:confing" that you refer to. Could anyone help me out? Thank you very much!
  • In Standalone, it's a button in the advanced tab of the Zotero preferences.
    In Firefox, you just paste about:config into the address bar and hit return.
  • wow, thank you very much for the quick answer! works fine now.
  • Hooray! this works great - thanks for the tip :)
  • This did not work for me in 5.0.17. I'm amazed the option to disable this has not been implemented nearly 6 years later. UK English sets off the little red lines. Terribly annoying. Please fix this. For the love of little apples, please.
  • That config option should definitely work. You need to restart Zotero after changing it.
  • If you're looking for how to disable the spellchecker in Zotero standalone, that seems to be possible now by going through the following steps:

    * From Zotero standalone, click on the Edit menu, then Preferences
    * Click on Advanced
    * Click on "Config Editor"
    * Acknowledge that you understand the risks
    * search for "extensions.spellcheck.inline.max-misspellings" (or just "spell" as this is * the only spelling option)
    * Double click on the text and change the value to 0
    * Close and reopen Zotero

    A previous poster noted that changing the value to 0 did not seem to have any effect. Now, setting the value to 0 seems to disable the spell check entirely, which is the behavior I was looking for. Thanks to the developers for the update.
Sign In or Register to comment.