Lost changes to note - When are changes to the note content saved?

Hi, I have the feeling that I am sometimes loosing data in Zotero notes. Yesterday I worked on a pretty long note and today I realized that the last changes I made to this note in the evening are not there anymore. How can that happen? When is the note content saved? I usually just kill my applications at some point (command-q). Could that be the reason why the last changes are not saved?
I just tried to reproduce this but I am not able too... So I guess it's not a general problem.


Mac OS 10.7.1
Zotero Standalone 3b2.1
  • If you close the note, the data is certainly saved. There's also an auto-save, but Dan will have to provide details.
  • I am sure I killed Zotero without closing the note (which was open in a separate note window). I guess that isn't a very good idea and maybe I lost the part between the last auto-save and the quitting!?
  • Auto-save should happen within a couple seconds of your stopping typing. If you can reproduce it not doing that, let us know.
Sign In or Register to comment.