Can not add any citations from new sources

After using zotero for a while I suddenly got a very strange error, when I add a new item to zotero i can not cite it in openoffice. While all the other items still work, i get the "An error occured communicating with zotero..." when trying to add a citation of this new source. I get this error after I press okay in the Add/Edit citation window. After trying it once with a new source all the old ones don't work anymore eigther unless I restart firefox an openoffice.

To me it seems as though there's a problem with my database, because if I export my library, delete my database and reimport my library, i don't have the problem anymore. but then again I have the problem that all my old citations get lost. So I would really be very glad if anyone could help me.

Thanks a lot
  • By the way, I do get the "Errors were found in Zotero database" when I run the test in Zotero preferences, and the onlinetool for repairing the database didn't solve the problem.
  • the following error appear in the report errors gui, when this happens:

    [JavaScript Error: "number.indexOf is not a function" {file: "chrome://zotero/content/xpcom/cite_compat.js" line: 1780}]
  • Okay I solved the problem: After some testing around I found out, that one particular citation in the file was making troubles when refreshing the bibliography, which is obviously done every time a new citation is introduced into the OOo file. After deleting this source from my library an manually redoing it I got it to work again.
Sign In or Register to comment.